Status

()

P3
critical
VERIFIED DUPLICATE of bug 40577
19 years ago
19 years ago

People

(Reporter: mikepinkerton, Assigned: clayton)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Above url crashes in:

PowerPC unmapped memory exception at 1032A6B4
 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  10442B68  
  11405E40    PPC  1042A00C  main+001BC
  11405DD0    PPC  10427578  main1(int, char**, nsISupports*)+009C8
  11405B50    PPC  12BB1374  nsAppShellService::Run()+00054
  11405B00    PPC  12AD5D24  nsAppShell::Run()+00040
  11405AC0    PPC  12AD65D4  nsMacMessagePump::DoMessagePump()+00044
  11405A70    PPC  12AD6E2C  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
001B0
  11405A20    PPC  12AF7230  Repeater::DoRepeaters(const EventRecord&)+0003C
  114059D0    PPC  12AA9A4C  nsMacNSPREventQueueHandler::RepeatAction(const 
EventRecord&)+000
14
  11405990    PPC  12AA9D28  nsMacNSPREventQueueHandler::ProcessPLEventQueue()+
00274
  11405900    PPC  128B2768  nsEventQueueImpl::ProcessPendingEvents()+00068
  11405890    PPC  1292B99C  PL_ProcessPendingEvents+00084
  11405840    PPC  1292BAE0  PL_HandleEvent+00054
  11405800    PPC  11BE23D4  nsStreamListenerEvent::HandlePLEvent(PLEvent*)+00050
  114057C0    PPC  11BE3A80  nsOnStopRequestEvent::HandleEvent()+000F4
  11405770    PPC  11C9CA60  nsHTTPServerListener::OnStopRequest(nsIChannel*, 
nsISupports*, u
nsigned int, const unsigned short*)+00190
  114056D0    PPC  11C8E994  nsHTTPChannel::ResponseCompleted(nsIStreamListener*, 
unsigned in
t, const unsigned short*)+000D4
  11405660    PPC  11C2FE20  InterceptStreamListener::OnStopRequest(nsIChannel*, 
nsISupports*
, unsigned int, const unsigned short*)+000F8
  11405610    PPC  11C9E45C  nsHTTPFinalListener::OnStopRequest(nsIChannel*, 
nsISupports*, un
signed int, const unsigned short*)+00118
  114055B0    PPC  11C20AA4  nsStreamLoader::OnStopRequest(nsIChannel*, 
nsISupports*, unsigne
d int, const unsigned short*)+00138
  11405550    PPC  102188F0  SheetLoadData::OnStreamComplete(nsIStreamLoader*, 
nsISupports*, 
unsigned int, unsigned int, const char*)+003BC
  11405470    PPC  10219650  CSSLoaderImpl::DidLoadStyle(nsIStreamLoader*, 
nsString*, SheetLo
adData*, unsigned int)+000C4
  114053D0    PPC  102193F0  CSSLoaderImpl::ParseSheet(nsIUnicharInputStream*, 
SheetLoadData*
, int&, nsICSSStyleSheet*&)+00150
  11405350    PPC  102191E4  CSSLoaderImpl::SheetComplete(nsICSSStyleSheet*, 
SheetLoadData*)+
00268
  114052D0    PPC  10218D64  CSSLoaderImpl::Cleanup(URLKey&, SheetLoadData*)+
00108
  11405250    PPC  12508D64  nsParser::EnableParser(int)+00070
  11405200    PPC  1250A29C  nsParser::ResumeParse(int, int)+0016C
  114051A0    PPC  1250A53C  nsParser::BuildModel()+00094
  11405150    PPC  124E57FC  CNavDTD::BuildModel(nsIParser*, nsITokenizer*, 
nsITokenObserver*
, nsIContentSink*)+001A4
  11405050    PPC  124E5F34  CNavDTD::HandleToken(CToken*, nsIParser*)+00380
  11404F40    PPC  124E8820  CNavDTD::HandleEndToken(CToken*)+000CC
  11404EC0    PPC  124EB8C8  CNavDTD::CloseContainer(const nsIParserNode*, 
nsHTMLTag, int)+00
110
  11404E70    PPC  124EB0EC  CNavDTD::CloseForm(const nsIParserNode*)+00050
  11404E30    PPC  0FE643E0  HTMLContentSink::CloseForm(const nsIParserNode&)+
000B4
  11404DE0    PPC  0FE5F398  SinkContext::DemoteContainer(const nsIParserNode&)+
00248
  11404D60    PPC  0FFB63F4  nsHTMLFormElement::RemoveChildAt(int, int)+00028
  11404D20    PPC  0FF59630  nsGenericHTMLContainerElement::RemoveChildAt(int, 
int)+000AC
  11404CD0    PPC  0FE781E8  nsHTMLDocument::ContentRemoved(nsIContent*, 
nsIContent*, int)+00
0B8
  11404C80    PPC  0FE005D8  nsDocument::ContentRemoved(nsIContent*, nsIContent*, 
int)+00058
  11404C30    PPC  0FE34DDC  PresShell::ContentRemoved(nsIDocument*, nsIContent*, 
nsIContent*
, int)+0009C
  11404BE0    PPC  0FE37888  PresShell::DidCauseReflow()+00044
  11404BA0    PPC  0FE34448  PresShell::FlushPendingNotifications()+00028
  11404B60    PPC  0FE37AD0  PresShell::ProcessReflowCommands(int)+001F8
  11404A50    PPC  0FF0F5E0  nsHTMLReflowCommand::Dispatch(nsIPresContext*, 
nsHTMLReflowMetri
cs&, const nsSize&, nsIRenderingContext&)+00254
  11404920    PPC  1019F170  ViewportFrame::Reflow(nsIPresContext*, 
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+002A8
  11404790    PPC  0FDF6568  nsContainerFrame::ReflowChild(nsIFrame*, 
nsIPresContext*, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, int, int, unsigned int, unsigned int&)+
00104
  11404680    PPC  102935E0  nsGfxScrollFrame::Reflow(nsIPresContext*, 
nsHTMLReflowMetrics&, 
const nsHTMLReflowState&, unsigned int&)+0005C
  114045D0    PPC  101E6400  nsBoxFrame::Reflow(nsIPresContext*, 
nsHTMLReflowMetrics&, const 
nsHTMLReflowState&, unsigned int&)+002A4
  114044F0    PPC  10294B3C  nsGfxScrollFrame::Layout(nsBoxLayoutState&)+0006C
  114044A0    PPC  10294D88  nsGfxScrollFrameInner::Layout(nsBoxLayoutState&)+
001B4
  11404300    PPC  10294A5C  nsGfxScrollFrameInner::LayoutBox(nsBoxLayoutState&, 
nsIBox*, con
st nsRect&)+00024
  114042C0    PPC  102FC614  nsContainerBox::LayoutChildAt(nsBoxLayoutState&, 
nsIBox*, const 
nsRect&)+00130
  11404260    PPC  10297A08  nsScrollPortFrame::Layout(nsBoxLayoutState&)+001A0
  114041D0    PPC  102F88D8  nsBoxToBlockAdaptor::Layout(nsBoxLayoutState&)+0018C
  11404110    PPC  102F9118  nsBoxToBlockAdaptor::Reflow(nsBoxLayoutState&, 
nsIPresContext*, 
nsHTMLReflowMetrics&, const nsHTMLReflowState&, unsigned int&, int, int, int, 
int, int)+006E0
  11403E90    PPC  0FF397BC  CanvasFrame::Reflow(nsIPresContext*, 
nsHTMLReflowMetrics&, const
 nsHTMLReflowState&, unsigned int&)+00274
  11403D00    PPC  0FDF6568  nsContainerFrame::ReflowChild(nsIFrame*, 
nsIPresContext*, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, int, int, unsigned int, unsigned int&)+
00104
  11403BF0    PPC  100E51D4  nsBlockFrame::Reflow(nsIPresContext*, 
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+01044
  11403410    PPC  101F5830  nsAbsoluteContainingBlock::Reflow(nsIFrame*, 
nsIPresContext*, co
nst nsHTMLReflowState&, int, int, nsRect&)+001D4
  114032C0    PPC  101F6024  
nsAbsoluteContainingBlock::ReflowAbsoluteFrame(nsIFrame*, nsIPre
sContext*, const nsHTMLReflowState&, int, int, nsIFrame*, nsReflowReason, 
unsigned int&)+0010
0
  11403140    PPC  10103D2C  nsHTMLReflowState::nsHTMLReflowState(nsIPresContext*
, const nsHT
MLReflowState&, nsIFrame*, const nsSize&, int, int)+0009C
  114030F0    PPC  10103E78  nsHTMLReflowState::Init(nsIPresContext*, int, int)+
000BC
  114030B0    PPC  1010798C  nsHTMLReflowState::InitConstraints(nsIPresContext*, 
int, int)+00
AF0
  11403010    PPC  10105728  
nsHTMLReflowState::InitAbsoluteConstraints(nsIPresContext*, cons
t nsHTMLReflowState*, int, int)+001A8
 Closing log
(Reporter)

Updated

19 years ago
Keywords: crash, dogfood

Comment 1

19 years ago
Crash reproduced with the 2000-05-25-08-M16 nightly binary on WinNT,
no content displayed; setting Platform/OS to All/All.

Talkback Incident ID to follow as soon as the blackbox transfers.

Updated

19 years ago
Severity: major → critical

Comment 2

19 years ago
Talkback incident ID for this crash: TB11198637Y
OS: Mac System 9.0 → All
Hardware: Macintosh → All

Comment 3

19 years ago
Page loads fine for me on PC/Linux with both 052508 and 052608 build.
Maybe the page content has changed significantly?

Comment 4

19 years ago
Anyway, the stack says that this is a dup of bug 40577 ("crash clicking outside
an abs. positioned frame"), which is fixed. Please reopen if anyone is still
seeing this.

*** This bug has been marked as a duplicate of 40577 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
Marking verified dup of 40577.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.