Closed Bug 405904 Opened 12 years ago Closed 2 years ago

Add API to XMLHttpRequest to enable callers to append the comment area in the UA string

Categories

(Core :: XML, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1188932

People

(Reporter: mozbugs, Unassigned)

Details

For stats purposes (or perhaps other things), it'd be nice if there was an easy way for an XMLHttpRequest to add to the comment area of the UA string to further signify what was making a request, be it an extension or some app functionality. This is better than an HTTP header because there isn't any extra configuration needed on the server end to record it, as it already shows up in most people's log configurations.
This feature would be accessible to extensions but not to web pages, right?
Right, chrome only feature.
see: http://www.mozilla.org/build/revised-user-agent-strings.html#implementation

It does apply for more than XMHttpRequest though.
(In reply to comment #3)
> see:
> http://www.mozilla.org/build/revised-user-agent-strings.html#implementation
> 
> It does apply for more than XMHttpRequest though.
> 

You mean the extra prefs? Doesn't that apply to *all* HTTP requests? The point of this is to differentiate between requests made by different extensions or components in the browser, as well as differentiate between directly user initiated requests.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1188932
You need to log in before you can comment on or make changes to this bug.