If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When Option "Fetch headers only" used, encrypted messages can not be decrypted and the message also can not be downloaded

RESOLVED DUPLICATE of bug 329955

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 329955
10 years ago
9 years ago

People

(Reporter: Max Vlasov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10
Build Identifier: 2.0.0.9 (20071031)

When Option "Fetch headers only" used, encrypted messages can not be decrypted. In this case Thunderbird displays a message: "Thunderbird cannot decrypt this message.." with the detailed explanation. Usually with this option ("Fetch headers ...) enabled every message appears initially with "Truncated!This message exceeded ..." message and the link "Click here" to download the complete message. With this scenario (encrypted message) this is not the case since in the "Thunderbird cannot..." message there is no link to download the whole message. The only way to download such message is not to select item in the list with Left click, but actually select it with the Right click and choose "Get Selected messages". After that everything is ok.

The bug is similar to 380744, but in that case the message was truncated occasionally and this time it's intentionally and the work around with "Get selected" shows it's probably a flaw in logics 

Reproducible: Always

Steps to Reproduce:
1. Select "Fetch Headers only" in a Thunderbird account 
2. Send an encrypted message to this account
3. Download messages and select the one that encrypted. 
Actual Results:  
Instead of the e-mail or a message to download e-mail completely, there's a message "Thunderbird cannot decrypt this message ..."

Expected Results:  
The usual message in this case:

"Truncated!This message exceeded the Maximum Message Size set in Account Settings, so we have only downloaded the first few lines from the mail server.
Click here to download the rest of the message."

Comment 1

9 years ago
I confirm. Same situation here! Please fix it.
Flags: wanted-thunderbird3?
Flags: blocking-thunderbird3?

Updated

9 years ago
Duplicate of this bug: 454152

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Flags: wanted-thunderbird3?
Flags: blocking-thunderbird3?
Resolution: --- → DUPLICATE
Duplicate of bug: 329955
You need to log in before you can comment on or make changes to this bug.