nsLoadCollector incorrectly handling loads

RESOLVED INVALID

Status

RESOLVED INVALID
11 years ago
8 years ago

People

(Reporter: alex, Assigned: pete)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
I'm running Minefield, and in the last few days the nsLoadCollector seems to have stopped working. It is something to do with the flags that are sent to the event listeners. This is all the debugging output I see when I hit reload on about:metrics 

This is causing <document /> events to not be logged.

stderr: 

WARNING: STATE_STOP without STATE_START: file nsLoadCollector.cpp, line 412

MS_LOG output:

-1610559488[507150]: LoadCollector: progress = 17cf0964, request = 17894b8c [about:metrics], flags = f0001, status = 0
-1610559488[507150]: LoadCollector: progress = 17cf0964, request = 17894b8c [about:metrics], flags = 30004, status = 0
-1610559488[507150]: LoadCollector: progress = 17cf0964, request = 17894b8c [about:metrics], flags = 20010, status = 0
(Assignee)

Comment 1

11 years ago
Alex, using a trunk build I synced today, I can't reproduce this.

When I type about:metrics I see my data - same when I reload ...

Do a cvs diff -u from your extensions/metrics dir and see if you have any local changes that may be causing this. 

Otherwise maybe I need some steps to reproduce. I am using the config.xml file you sent me today.

(CC'ing Jan)
Status: NEW → ASSIGNED
(Reporter)

Comment 2

11 years ago
Are you seeing the <document /> along with the <uielement /> tags? 
(Assignee)

Comment 3

11 years ago
Created attachment 290903 [details]
about:metrics output
(Assignee)

Comment 4

11 years ago
I don't see any warnings or assertions running or when I reload about:metrics.

So I need some steps to reproduce this bug.
(Reporter)

Comment 5

11 years ago
(In reply to comment #4)
> I don't see any warnings or assertions running or when I reload about:metrics.
> 
> So I need some steps to reproduce this bug.
> 

I have none, it just quit working. I'm going to assume it has something to do with an API change for now (I built the extension awhile ago). I'll reopen if it pops up again.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Updated

8 years ago
Component: Data Collection/Metrics → Data Collection/Metrics
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.