Firefox incorrectly converts POSTs to GETs in response to 301 and 302 status codes

RESOLVED DUPLICATE of bug 190630

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 190630
11 years ago
11 years ago

People

(Reporter: Keith Gaughan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071126 Ubuntu/7.10 (gutsy) Firefox/2.0.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071126 Ubuntu/7.10 (gutsy) Firefox/2.0.0.10

A conformant HTTP 1.1 user agent is meant on receiving a 301 (Moved Permanently)
or 302 (Moved Temporarily) to redirect the original response to the new
location given in the Location header, otherwise preserving the original
request and possibly notifying the user that their POST request is being
redirected elsewhere.

Instead, Firefox is treating 301 and 302 redirects like 303 (See Other)
redirects, where the 'Location' header indicates where the newly created
resource is.

In the demonstration page given, the destination page should specify the request
method as POST where a 301 or 302 status code was used, and GET in response to
the 303 status code.

Reproducible: Always

Steps to Reproduce:
1. Go to to the URL specified.
2. Select either a 301 or 302 redirect from the dropdown.
3. Click submit.
Actual Results:  
The response page says the request method used was 'GET'.

Expected Results:  
It should be 'POST'.

The demo source is available for viewing here: http://www.blacknight.com/tests/ffredirect/orig.php?source=1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 190630
You need to log in before you can comment on or make changes to this bug.