Closed Bug 406164 Opened 12 years ago Closed 7 years ago

starbucks.com - Unable to display search results for store locations

Categories

(Tech Evangelism Graveyard :: English US, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: marcia, Unassigned)

References

()

Details

Seen while running Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2pre) Gecko/2007113004 Minefield/3.0b2pre.

STR:

1. Visit the URL above. Type in San Jose, CA to search for stores.
2. Observe that you get a dialog that says "Searching" but the search results are never shown.

This works using Safari, I get the results.
WFM on today's nightly, Windows Vista 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007113005 Minefield/3.0b2pre Firefox/3.0 ID:2007113005
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
Virtual Earth does Firefox specific ua detection in 
<http://dev.virtualearth.net/mapcontrol/mapcontrol.ashx?v=6>

We should probably file a bug on them.
Blocks: geckoisgecko
OS: Mac OS X → All
Hardware: Macintosh → All
Summary: Unable to display search results for Starbucks retail store locations → starbucks.com - Unable to display search results for store locations
While trying to reproduce this bug, I think I ran into another example of it. If you try searching for a store from the homepage (http://www.starbucks.com/), you get an error in the error console saying:

Error: uncaught exception: Msn.Drawing.Exception: Your Web browser does not support SVG or VML. Some graphics features may not function properly.

This works fine in IE7 and Safari.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2007122105 Minefield/3.0b3pre ID:2007122105
(In reply to comment #2)
> Virtual Earth does Firefox specific ua detection in 
> <http://dev.virtualearth.net/mapcontrol/mapcontrol.ashx?v=6>
> 
> We should probably file a bug on them.

Was this ever done, Bob? I don't recall seeing it.

cl

(In reply to comment #4)

> Was this ever done, Bob? I don't recall seeing it.

I think bug 363175 is it.
Depends on: MS, 363175
The search URL in comment 0 is no more valid.
The correct URL is now http://www.starbucks.com/store-locator

This bug is WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
Nope, this is definitely still broken without "like Firefox" in the UA in a recent Camino nightly. I never get any action at all when typing in a city name and clicking "Go" or pressing Return/Enter.

Restoring the default Camino UA makes this work immediately, so it's definitely as simple as Starbucks still being stupid.

However, I don't think it's dependent on anything on Microsoft's end now. I'm going to remove those dependencies unless someone can show this problem *isn't* purely Starbucks's fault.

Did anyone ever contact Starbucks about this? We definitely need to now, because they no longer have the excuse of a bad third-party API.

cl
Problem not found
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
(also tested with Camino UA)
No maps in Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 SeaMonkey/2.20; Build ID: 20130721212621
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Installed last SeaMonkey release on Ubuntu, disabled general.useragent.compatMode.firefox, verified that the UA string in about: is "Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 SeaMonkey/2.19" (Build id: 20130628213754, BTW), deleted private data and local storage - map still WFM. 

Maybe you've stumbled upon a regression between 2.19 and 2.20?? Any errors in the console?
(In reply to Hallvord R. M. Steen from comment #11)
> Maybe you've stumbled upon a regression between 2.19 and 2.20?? Any errors
> in the console?

Maps fail to load in Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 SeaMonkey/2.19; Build ID: 20130628213754 also. Error console loads with far too many to count after clear then reload starbucks page. This one is my main profile with about 50 tabs open and noscript extension. The comment 10 profile uses no extensions that are not bundled in the SM bzip2. I'm running KDE3 on openSUSE, where maps load normally in FF22. I collect the UA string from http://fm.no-ip.com/Auth/dpi-screen-window.html to paste. When I load 2.19 with a virgin/test profile, maps load. I originally had no idea what the two other profiles could have in common to block those maps from loading. After some thinking, I went to Javascript prefs. My regular profiles have all in the list of 6 unchecked. Unchecking allow JS to change images is what prevents the maps from loading. I'm guessing this one will turn out to be what's been annoying me on eBay and other frequented pages.
There is a pref to disallow JS from changing images? 8-o

In any case, I close this as invalid, since the problem was caused by your config (and it's reasonable to expect that a JS-powered graphic app like Maps will not work if JS is not allowed to change IMG src - indeed doing so is the most efficient way to implement what Maps is doing).
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.