Closed Bug 406168 Opened 12 years ago Closed 12 years ago

Infinite loop when opening JS console

Categories

(Core :: Disability Access APIs, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: aaronlev, Assigned: aaronlev)

References

Details

(Keywords: access, crash, regression)

Attachments

(1 file)

I wasn't able to get this every time, but I have a stack and understand the issue.

It's a regression from bug 385070.

What happens is that nsAccessNode::Init() get's the parent's child count, and that causes a reentry error if the reason we're initting that nsAccessNode is it's being created to get the parent's child count.
Attached patch Prevent reentrySplinter Review
Attachment #290877 - Flags: review?(surkov.alexander)
Comment on attachment 290877 [details] [diff] [review]
Prevent reentry

looks good.
Attachment #290877 - Flags: review+
Attachment #290877 - Flags: review?(surkov.alexander) → approval1.9?
Attachment #290877 - Flags: approval1.9? → approval1.9+
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Blocks: 406595
You need to log in before you can comment on or make changes to this bug.