Closed Bug 406208 Opened 13 years ago Closed 13 years ago

problems with bookmark restore

Categories

(Firefox :: Bookmarks & History, defect, P4)

defect

Tracking

()

RESOLVED DUPLICATE of bug 384370

People

(Reporter: moco, Unassigned)

References

Details

problems with bookmark restore

the following should work:

1) user quits
2) removes places.sqlite
3) starts up
4) default top level folders and places smart folders are restored (bug logged on the top level issue)
5) restore from the places organizer restores properly (toolbar, unfiled, tags.)  toolbar should work now, unfiled (we have a bug), tags (waiting for json, I think, may not work properly with html as we don't export.)

robert tried this, and is having problems.  I'll report back with the exact problems.

note, people will remove places.sqlite (power users, I know), but this could also happen if places.sqlite becomes corrupt
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P3
Target Milestone: --- → Firefox 3 M11
Target Milestone: Firefox 3 beta3 → ---
Priority: P3 → P4
(In reply to comment #0)
> problems with bookmark restore
> 
> the following should work:
> 
> 1) user quits
> 2) removes places.sqlite
> 3) starts up
> 4) default top level folders and places smart folders are restored (bug logged
> on the top level issue)
> 5) restore from the places organizer restores properly (toolbar, unfiled,
> tags.)  toolbar should work now, unfiled (we have a bug), tags (waiting for
> json, I think, may not work properly with html as we don't export.)
> 
> robert tried this, and is having problems.  I'll report back with the exact
> problems.
> 
> note, people will remove places.sqlite (power users, I know), but this could
> also happen if places.sqlite becomes corrupt
> 

why are we blocking on a bug that does not have a reported problem? :P

that aside, "restore" will be fixed in bug 384370.

after bug 384370 the landscape will look like:

import/export = html = no tags, unfiled
backup/restore = json = everything

better than the status quo, but not ideal: it's not clear from the UI that either is a different format, nor that import/export is limited to the menu and toolbar. after that bug lands, we should morph this bug into "problems with bookmark import".

Depends on: 384370
the STR in comment #1 are fixed by bug 384370. if there are specific problems you can still reproduce, please file a followup for the specific issue.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 384370
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.