should the "star" and "tag" icons in the autocomplete results be in another location (not on the far right)?

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

should the "star" and "tag" icons in the autocomplete results be in another location (not on the far right)?

discussing with faaborg yesterday, it's nice how now the favicon, url, and title are all on the left, unlike before where the favicon and url were on the left and the title and star/tag icon was on the right.

perhaps we should figure out how to move the tag/star icon to the left as well, so I don't have to look all the way to the right to see if the result is "starred" / "tagged"?
I'll be posting a new mockup over in bug 393508
No longer depends on: 393508
So, I think that these icons are less important, but represent useful context.  I don't think adding more weight to the left is a good thing at this point, and I don't think this is the important data anyway.

Comment 3

11 years ago
The Star is a nice feature. But I think about a highlight of the Text, so that the User can see which page is a favorite or only a already-visited (history) page easiliere. 

Comment 4

11 years ago
//EDIT: The Idea from Seth Spitzer (perhaps we should figure out how to move the tag/star icon to the left as well,
so I don't have to look all the way to the right to see if the result is
"starred" / "tagged"?) is maybe much better than a highlighted text.

Comment 5

10 years ago
This might be something to look into if bug 401660 lands which will put the page tags into the title like.. "Title (tags)      <tagicon>".
Beltzner proposed on a white board today:

Page Title Goes Here (<tagicon> tags)
http://thisistheurl.com

We thought this would work best if (tags) were in a different font color as well to separate it from a title that contains parentheses.

Comment 7

10 years ago
What if the title is really long? Same thing for the star icon? (Put it right after the title?)
>What if the title is really long?

I sort of remember another bug about concatenating the title to show the matching section.  Ideally if that got solved, we would leverage that to show the tag match.  Otherwise, I wouldn't worry about it given our ship schedule.

>Same thing for the star icon?

It's important that the star remains vertically aligned with the control to bookmark a page, because that helps user's learn what that control is for (they notice that an existing bookmark in the results has a star).

Updated

10 years ago
Blocks: 406237
Duplicate of this bug: 406237
This seems to be WORKSFORME given the UX guidance in this bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.