Assertion "Possibly stale float cache here!" fires incorrectly

RESOLVED FIXED

Status

()

Core
Layout: Block and Inline
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: roc, Assigned: roc)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 290966 [details] [diff] [review]
obvious patch

The assertion was added in bug 406137:
  NS_ASSERTION(!line->HasFloats(), "Possibly stale float cache here!");

This fires a lot. The problem is, it fires for lines that aren't dirty, which is wrong, because the float caches for non-dirty line will be just fine. Obvious/trivial patch attached.
Attachment #290966 - Flags: superreview?(dbaron)
Attachment #290966 - Flags: review?(dbaron)
Comment on attachment 290966 [details] [diff] [review]
obvious patch

r+sr+a1.9=dbaron
Attachment #290966 - Flags: superreview?(dbaron)
Attachment #290966 - Flags: superreview+
Attachment #290966 - Flags: review?(dbaron)
Attachment #290966 - Flags: review+
Attachment #290966 - Flags: approval1.9+
checked in
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.