Some fonts are rendered too big and bold when they shouldn't

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Fabian A. Scherschel, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: NotABug, Nvidia, URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

On certain websites, Firefox 3 renders some fonts bigger than Firefox 2 and also makes text bold that other browsers (IE7, Opera, Firefox 2) render as unemphasized. It looks like this only happens with "default fonts" (ie. fonts with no or minimal CSS attributes applied) and I have only seen it happen with sans-serif fonts like Arial and Verdana (or open source alternatives of those).

Reproducible: Always

Steps to Reproduce:
1. Visit a website that causes Firefox to display the fonts in this way (ie. Libsyn.com)
2.
3.
Actual Results:  
Some text is displayed too big and bold, which makes the site look very ugly and in some cases breaks the design of the affected sites.

Expected Results:  
Text should be displayed as it is displayed when I visit the site in Firefox 2.
(Reporter)

Comment 1

11 years ago
I am using Ubuntu 7.10 Gutsy Gibbon with the latest patches. FF version is Firefox 3 Beta 1.
Version: unspecified → Trunk

Comment 2

11 years ago
Looks the same to me Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007120104 Minefield/3.0b2pre ID:2007120104 and Firefox 2.0.0.11

Comment 3

11 years ago
CONFIRMED.

Build Info:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008012104 Minefield/3.0b3pre

Compared to 2.0.0.11 and Konqueror 3.5.8

KDE and Kubuntu 7.10

Comment 4

11 years ago
Confirmed 
Using MAC - OS X v 10.5.2
- Different fonts are showing when comparing the same WEB page: 
www.Libsyn.com on 3 monitors comparing Safari with FF2 - have the same fonts and FF3 - shows different fonts
Specific item:
Forgot password on Safari 3 and FF2 - Notice the "ord" of password extends beyond the textbox but not on FF 3

Comment 5

10 years ago
Created attachment 313721 [details]
different issue; disregard

I'm getting this too.  I first thought it was just finding better fonts to match the requested ones, but I checked in WinXp and it's much better there.

Attached is a comparison of the rather drastically different font spacings I'm seeing on BabelZilla's forums.  (Mandriva Linux 2008, KDE 3.5.9, Firefox 2.0.0.13 vs. Firefox 3.0b5)

Comment 6

10 years ago
Now I'm being told that these are different fonts altogether.  My issue may be slightly different, not sure.  Hopefully someone more knowledgeable can weigh in on this.

Comment 7

10 years ago
Comment on attachment 313721 [details]
different issue; disregard

Sorry, my font issue was different from this one.  Seems to have been a problem with my distro which is fixed in their latest release.  Please disregard my previous comment.
Attachment #313721 - Attachment description: FF2 vs. FF3 fonts on Linux → different issue; disregard
Attachment #313721 - Attachment is obsolete: true

Comment 8

10 years ago
Created attachment 317941 [details]
screenshot of problem

Comment 9

10 years ago
I didn't have time to write my reply when I submitted the screen shot, so here it goes. 

This first occurred when I upgraded to Ubuntu 8.04.  At first I thought it might have been because I updated some font rendering library and now the settings were all messed up (or something along those lines).  However, I reinstalled Firefox 2 and there is no problem (the fonts render at the correct size).

I'm going to do some more investigating into this, but as of now I will say what I know.  The screen shot is of a vB forum and I noticed that this happens on all vB forums I have visited.  Looking at the CSS, I notice that sites where the problem occurs tend to use the pt unit for font sizes (as opposed to px, em, %).  I haven't done enough testing to see if this is actually the culprit, but if it is I don't understand what the trigger is (why does this only happen for some people?).

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008041515 Firefox/3.0b5

Let me know if I need to post additional information about my setup.

Comment 10

10 years ago
I'm not sure why this only happened with some fonts (and only with FF3), but I figured out what causes the problem (and have resolved it).

I recently reinstalled Ubuntu 8.04 and the problem didn't occur.  I then loaded up the proprietary nvidia driver, and the problem reappeared. Apparently, the nvidia driver had a different DPI setting than that of the vesa driver.  I fixed the problem by manually setting my DPI, per the article at: http://gentoo-wiki.com/HOWTO_Set_DPI_(Dots_Per_Inch).  The main thing to remember is that you need to set UseEdidDpi to false, or else nvidia will use what the monitor "recommends."

Hopefully this helps others with the same problem.

Comment 11

10 years ago
Tested on a laptop with an nvidia card - same issue with the same correction. Resolving as INVALID, as the bug is not a valid FF3 bug, rather an nvidia/vesa driver difference. 

Please re-open if problem persists and the above fix does not work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Whiteboard: NotABug, Nvidia
You need to log in before you can comment on or make changes to this bug.