missing carriage returns

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: TR, Unassigned)

Tracking

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: version 2.0.0.9 (20071031)

When sending or viewing a sent message with two or more carriage returns at the end of some text (e.g. when inserting a blank line between paragraphs), one of the carriage returns is deleted if there are any spaces before the first carriage return.  This results in difficult to read messages.  This bug is similar to bug 125928, which appears to have been fixed for composing messages in html, but not text.  It seems to differ from 125928 in that even only one space before the first carriage return causes this behavior.

Reproducible: Always

Steps to Reproduce:
1. Type Hello.<space><enter><enter>Hello.
2. Click send.

Actual Results:  
Sent and received message will read Hello.<space><enter>Hello.  There is no blank line between the two Hellos.

Expected Results:  
Hello.<space><enter><enter>Hello again.  There should be a blank line between the two Hellos.

This bug is probably present in all versions, although I've only encountered it using Windows XP and Vista.

Comment 1

11 years ago
Bug 125928 is only (partly) fixed on trunk- you need a 3.0a1pre build to see the fix. Seems to work fine for me (both plain text and html composition) on latest linux trunk build.

Comment 2

10 years ago
I'm experiencing this bug on Linux. I'm able to reproduce the problem exactly as suggested above in the original bug report. I recently posted a message to the forums before finding this post, quoted here for completeness:

I'm having trouble with carriage returns disappearing when I send mail. This is happening when sending plain text emails. When I look at the text in the editor, it appears the way I want, but if I look at the sent mail in either another program or even my sent folder, it does not appear as it did when sending it. If I then go and "Edit as New" the mail, it again appears with the carriage returns how I originally intended. How can I fix this?

OS: Linux kubuntu 2.6.24-19-generic #1 SMP Wed Jun 18 14:43:41 UTC 2008 i686 GNU/Linux
Thunderbird: version 2.0.0.14 (20080505)

Comment 3

9 years ago
AS it stands, it appears you need to have a space on the empty line - you can't get by with just a line preak.

I have been having this problem for months. Am on current Thunderbird build version 2.0.0.23 (20090812) now. This problem has existed for some time previous, maybe forever, not sure. 

Sure would be great to get a fix. 

Thanks.. Tim
WFM here on 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091009 Lightning/1.0pre Shredder/3.0pre ID:20091009032155

Reporter 2.X is a security fix and maintainance branch it's very
unlikely that what fixed this bug ends up backported to the 2.x branch. 

Please try latest official beta at 
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/downloads/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 2.0

Updated

9 years ago
Duplicate of this bug: 471422
You need to log in before you can comment on or make changes to this bug.