Typing in URL autoselects itself if browser.urlbar.clickSelectsAll is set to true

VERIFIED FIXED in Firefox 3 beta3

Status

()

Firefox
Address Bar
P3
major
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: pascalc, Assigned: dao)

Tracking

({regression})

Trunk
Firefox 3 beta3
x86
Linux
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
tested with Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9b2pre) Gecko/2007120104 Minefield/3.0b2pre

Steps to reproduce the bug :
1/ type about:config and set browser.urlbar.clickSelectsAll to true
2/ go to any page, click on the urlbar and type an address, say google.com

expected result:
google.com is displayed

actual result:
oogle.com is entered because after hitting g, the letter autoselects itself and is then replace by the rest of what you type

This is a regression since Firefox3beta1 does not have this bug.

Comment 1

11 years ago
Confirming for : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007120304 Minefield/3.0b2pre


Normal comportment  in Windows and mac OSX.

Perhaps a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=218216 ?

But this comportment is new under linux since beta1
 
Severity: normal → major
Flags: blocking-firefox3?
(Reporter)

Comment 2

11 years ago
Another effect of this big :


1/ go to any URL like https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox
2/ select part of the url with the mouse lile 'enter_bug' for instance
3/ hit DEL key

Expected result:
delete part selected

Actual result:
the whole URL is selected

There are probably more weird selection issues in the location bar when clickSelectsAll is set to true on linux
i can confirm the bug report from pascal, comment #2 but not the inital bug report from comment #0 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2pre) Gecko/2007120304 Minefield/3.0b2pre on Leopard
(Reporter)

Comment 4

11 years ago
I filed bug #406690 for the bug I described in comment #2

Updated

11 years ago
Assignee: nobody → dao
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P3
Target Milestone: --- → Firefox 3 M11
(Assignee)

Updated

11 years ago
Blocks: 398020
Status: NEW → ASSIGNED
Depends on: 397299
(Assignee)

Comment 5

11 years ago
Created attachment 292629 [details] [diff] [review]
hack isn't needed anymore, remove it
Attachment #292629 - Flags: review?(mconnor)

Updated

11 years ago
Attachment #292629 - Flags: review?(mconnor) → review+
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
Checking in browser/base/content/browser.js;
/cvsroot/mozilla/browser/base/content/browser.js,v  <--  browser.js
new revision: 1.910; previous revision: 1.909
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Summary: typing in URL autoselects itself if browser.urlbar.clickSelectsAll is set to true → Typing in URL autoselects itself if browser.urlbar.clickSelectsAll is set to true
Duplicate of this bug: 408028
Duplicate of this bug: 409212
Duplicate of this bug: 409201
Duplicate of this bug: 409098
Duplicate of this bug: 409776

Updated

11 years ago
Duplicate of this bug: 409934
verified fixed using Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b3pre) Gecko/2007122704 Minefield/3.0b3pre and the steps to reproduce from comment #0.

-> Verified fixed 
Status: RESOLVED → VERIFIED

Updated

11 years ago
Duplicate of this bug: 410210

Updated

11 years ago
Duplicate of this bug: 410980
You need to log in before you can comment on or make changes to this bug.