Scrollbars malfunction on viewer demo #15 (XML IRS)

RESOLVED WORKSFORME

Status

()

Core
XML
P3
normal
RESOLVED WORKSFORME
18 years ago
3 years ago

People

(Reporter: jeffw, Assigned: Chris Petersen)

Tracking

({polish})

Trunk
x86
Windows 98
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-], URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m16) Gecko/20000525
BuildID:    2000052508

In viewer demo #15 (XML IRS), clicking on the "Contents" button pops up a table
of contents on the left. If I click and drag the scrollbar for the TOC, the
content of the frame scrolls, but the scrollbar doesn't actually move. Scrolling
the main frame leads to all sorts of widget wackiness in the TOC scrollbar; this
goes away if you make it redraw the scrollbar--say, by minimizing and maximizing
the window.

Also, clicking inside the TOC frame doesn't give it focus; separate bug?

Reproducible: Always
Steps to Reproduce:
1. Open Mozilla.
2. Go to Debug|Viewer Demos|#15 XML IRS.
3. Click on the Contents button.
4. Scroll the TOC frame.
5. Then scroll the main frame.

Actual Results:  (4): The content moves, but the scrollbar doesn't. (5): The TOC
scrollbar gets all messed up--the arrows smear across the scrollbar.

Expected Results:  (4): Both the content and the scrollbar should move. (5):
Nothing should happen to the TOC scrollbar.
(Reporter)

Comment 1

18 years ago
*** Bug 40645 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

18 years ago
Still seeing this on 2000060408 build on win98.

Comment 3

18 years ago
setting to new
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
It would really help if we had a reduced test case for this one.  Setting target 
milestone to M19 for now and adding qawanted to the keyword field.
Status: NEW → ASSIGNED
Keywords: qawanted
Target Milestone: --- → M19

Comment 5

18 years ago
Since the XML demo is a frequently accessed page and is a showcase of Netscape 
6's XML functionality, we should try to make this work properly for nsbeta3.  
Nominating...
Keywords: nsbeta3
Keywords: polish

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 41294 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
Adding keyword 'verifyme' to bug.
Keywords: verifyme

Updated

17 years ago
QA Contact: chrisd → petersen

Comment 8

17 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Keywords: verifyme
I do not believe this is a dup of bug 41294. That bug is about wrong scrolling 
when you select and drag text, this bug is about scrollbars. Reopening.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 10

17 years ago
Not seeing this on the classic skin on an NT box with a recent debug build.  
Could we get some testing on this on Mac/Windows/Linux with the modern/classic 
skins?  For now, marking nsbeta3-.
Whiteboard: [nsbeta3-]
(Reporter)

Comment 11

17 years ago
No longer seeing this on 2000091108 build on Win98. I tested both the classic
and modern skins.
(Reporter)

Comment 12

17 years ago
Still not seeing this in Win98 with 2000092808 build; I tested classic and
modern skins. Can Linux/Mac people verify that this is fixed?

Comment 13

17 years ago
worksforme with modern skin *only*, mozilla build 2000092804-M18, Mac OS 9.0.4.

I was having some trouble bouncing between modern and classic skins with this
build, but that's another bug.  Will test both skins further with a later build,
perhaps next week.

Comment 14

17 years ago
Still not 100% working on Mac, but this could be related to event handling.

Under Mozilla build 2000100208-M18, I was unable to get the "Contents" button to
pop the table up.  Click on button -- nothing happened.  Got the button to work
*once* after reloading the page in Modern theme, but button wouldn't work at all
in Classic theme.

So... I couldn't really test this bug tonight, but will have to retest with a
later build.  Any idea where the event handling bug report should go?
(Reporter)

Comment 15

17 years ago
Kurt, I think you're seeing the behavior I described in 54622, which is 
currently UNCONFIRMED. Can you verify my description on Mac and add an 
appropriate comment to that bug?

Comment 16

17 years ago
Now completely busted with Modern theme on the Mac.  iMac DV, Mac OS 9.0.4, Moz
build 2000100720-M18.

Comment 17

17 years ago
*Seems*, repeat seems to work with Mac Mozilla trunk build 2000111008 running
under Mac OS 9.0.4.

But Mozilla took a couple seconds to think about it.  May get to try this again
with a later build, but I'm busy this week...

Comment 18

17 years ago
Chris, please test this bug with a current build on Mac, Windows, and Linux and 
update this bug report.  If you see problems, please re-assign the bug back to 
me.  Thanks.
Assignee: nisheeth → petersen
Status: REOPENED → NEW

Comment 19

16 years ago
Making test case.  
The original problem #4 still occurs on Linux 2002011100 (scrollbar doesn't
scroll), but not problem #5 (problems scrolling main frame).

Comment 20

16 years ago
no scrollbar problems seen on Windows 2000 with current build.

Jake
I am closing this as worksforme, win2k & linux builds 1/17.

There is still the focus problem (click inside TOC, scrolling by keyboard
scrolls main window) but a separate bug should be filed for that.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
QA Contact: petersen → rakeshmishra
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.