Text display lags behind typing on form submission

VERIFIED FIXED in M17

Status

()

Core
HTML: Form Submission
P3
critical
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Kurt Weinschenker, Assigned: Simon Fraser)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; m16) Gecko/20000524
BuildID:    2000052408

When I point mozilla to the above URL, the text display will start lagging
behind my typing about seven characters or so in.

Reproducible: Always
Steps to Reproduce:
1.Point mozilla to a favorite bug in bugzilla.
2. Attempt to enter comment
3.

Actual Results:  Text lagged behind actual typing.

Expected Results:  Text should have matched actual typing.

iMac DV, Mac OS 9.0.4, MRJ 2.2, carbon libs 1.0.4.

"Font Resolution" preference was set to 72 dpi to more closely track Macintosh
display.

Text will reveal if page up/page down scrollbar command is given.

Form will take text one has typed in after submission (such as what I've just
typed).

Comment 1

18 years ago
*** Bug 40648 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
reassigning
Assignee: rods → beppe

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
m17
Target Milestone: --- → M17

Comment 4

18 years ago
reassign to sfraser; he has a fix
Assignee: beppe → sfraser
Keywords: dogfood, nsbeta2

Comment 5

18 years ago
the severity on this bug is not normal; when you get hit by this you can't see 
what you've typed until you've typed 2 additional words (and then you can't see 
those).  Upping severity to critical (not a blocker because it doesn't crash and 
you can work around by constantly forcing the window to repaint by dragging the 
window around <ugh>)
Severity: normal → critical
(Assignee)

Comment 6

18 years ago
*** Bug 40706 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

18 years ago
Damn, this isn't fixed by my fix for text rendering.

Status: NEW → ASSIGNED
(Assignee)

Comment 8

18 years ago
Oh, good, my fix did fix this.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
Marking VERIFIED FIXED on:
- MacOS9 2000-07-06-08-M17 Commercial
- Linux6 2000-07-09-20-M17 Commercial
- Win98  2000-07-09-21-M17 Commercial
Status: RESOLVED → VERIFIED

Updated

14 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.