Message sometimes hidden in inbox, if subject header is empty

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Morten Lemvigh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-03-25)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071126 Ubuntu/7.10 (gutsy) Firefox/2.0.0.10
Build Identifier: version 2.0.0.6 (20071022)

Sometimes a new message is hidden in the inbox. There is a (1) next to "Inbox" indicating a new message has arrived, but it is not displayed in the message list.

If I happen to know, who send it, and search for the sender in the search field, the message is shown. After I clear the search field, the message is hidden from the list again.

If I search for the message, and then move it to another local folder it is visible in that folder (without searching for it). If I move it back again to the inbox, it is hidden again.

I have only experienced this with messages having an empty subject header. But sometimes I have not been able to find the message using search (if I didn't know who send it) so it might cover other messages as well. It doesn't happen to all messages with empty subject header though.

Reproducible: Sometimes

Comment 1

11 years ago
"Rebuild index" (in folder properties) might help.

Comment 2

11 years ago
I have the same problem, sometimes (about once a month) a new mail from a pop3 account is downloaded to inbox, it appears as one unread message next to the inbox folder, but there seems to be no new message in the folder. the new mail is also shown as a popup. 

a difference: it seems to happen randomly, also with mails with no empty subject header!

rebuild index helps.

My Thunderbird version is also 2.0.0.6 and i'm running linux, too. (kubuntu)

Comment 3

9 years ago
I had the same problem March 2009, several times. Messages with no subject becomes invisible. Saw this when mail came from web based e-mail account. 

When mailing to myself from the same machine using Thunderbird a message with no subject stayed visible.

I am running Thunderbird 2.0.0.21 on a Windows Vista Machine.

This bug is very annoying and hazardous to users.

Comment 4

9 years ago
Performed "Rebuild index" (in folder properties) as suggested above in comment #1 and mails previously invisible appeared.

Comment 5

9 years ago
I have had this problem couple of times. The messages that didn't show up were sent with a Thunderbird to a mailing list. They were filtered correctly to another folder, and the folder list showed 1 unread message. 

The missing message shows up if I specifically search for it or move it to another folder. Rebuilding index made the message visible. None of the messages had an empty subject line; it would make sense to change the title of this bug report.

I'm using Thunderbird version 2.0.0.21 (20090318) on Ubuntu 8.04.2.
Can any of the people that have the issue make sure to save the message that exhibits the issue and attach it to this bug next time they have that problem ?
Created attachment 380548 [details]
message which was hiding in the Inbox
It happened to me today with version TB 2.0.0.21 (20090302) on Windows XP.
The message was saved and attached as attachment 380548 [details]

Comment 9

9 years ago
I doubt this has to do with the subject of the message being empty; it's more likely it has to do with the subject being the same as the subject of a message that was the last message in a thread, and was deleted. Which makes me think this is a dup of bug 414723.

Comment 10

9 years ago
is this gone for you in version 3?  (bug 414723 is fixed in v3)
Component: Mail Window Front End → Folder and Message Lists
QA Contact: front-end → folders-message-lists
Whiteboard: closeme 2010-03-25
Version: unspecified → 2.0
(In reply to comment #10)
> is this gone for you in version 3?  (bug 414723 is fixed in v3)

I have not experienced this effect for quite some time.

I began using V3 only recently, so the above refers, mostly, to V2* (and to whether provoking factors had a chance to cooperate.)
(In reply to comment #10)
> is this gone for you in version 3?  (bug 414723 is fixed in v3)

BTW, I've noticed that the "platform" is set to "x86 Linux". I experienced the bug on <b>MS windows XP </b>, and I am sure I filed the platform as such...
RESO WFM per comment 11.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.