If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Flash misrendering only on Firefox 3 (same flash on Firefox2 is good!)

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: xpert lamer, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10

The 400x400 pixel sized flash at the bottom of the page is invisible
with both MineField pre-beta and Firefox 3 Beta 1 on the very same machine and
Operating System, however with Firefox 2.0.0.x and below
and with "Minefield and Gran Paradiso Alphas" (!) is visible to me.

You should see there a young boy with funny "Hitler" mustache and some "parallax" scroll trick , like his nose moves in 2,5 dimension.

I misgive the problem causes by my low CPU (is 300 Mhz) and therefore cannot
render correctly the page with new gecko engine neither on Minefield pre-beta nor on Firefox 3 Beta 1, 

because an other guy here said he is able to see my flash on that page
with Firefox 3 Beta 1 (on Windows of course)

I have tried several times uninstall and then re-install Firefox versions, and then re-ghost my whole system, but this problem seems persistent to me.

Same flash however on an other page, is visible with the same code ( embed , wmode=transparent ), and with its
original background color , so it seems "Firefox 3 Beta 1" only cannot render correctly the wmode=transparent mode on a week CPU.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

10 years ago
Severity: critical → major
Component: General → Plug-ins
Product: Firefox → Core
Version: unspecified → Trunk
QA Contact: general → plugins
(Reporter)

Comment 1

10 years ago
I have tested with two different machines (the other is near 2 Ghz)
, with all color depths and i've got unfortunately the same results ! Even on Mozilla Firefox 3 Beta 2 !

However on the same machines on the same Operating Systems 
the same flash is visible as well with Firefox 2.x.x.x


(Reporter)

Updated

10 years ago
Summary: Invisible Flash with wmode=transparent on low CPU → Flash misrendering only on Firefox 3 (same flash on Firefox2 is good!)
(Reporter)

Comment 2

10 years ago
I have now tested with Beta 3 but problem is still exist. The young boy is invisible with Firefox 3, but visible with Firefox 2 with the very same machine and configuration. I think it maybe because of my video card knows only 16 bit and 24 bit mode, but there is no 32 bit mode. Perhaps you use the windows built in upper 8 bit transparent channel of 32 bit palette to render the flash plugins' wmode=transparent... i don't know.. but the problem is real, and still exists !!!
Severity: major → critical
(Reporter)

Comment 3

10 years ago
((( anyway  firefox 3 beta 3 is much much slower than previous beta and minefield versions was, however the typein history of URL is pretty useful ! )))
WFM on XP, trunk. Shockwave Flash 9.0 r45
and vista, trunk Shockwave Flash 9.0 r115

what is your version of flash?

Comment 5

10 years ago
With Firefox 3 beta 4 (Win XP) I'm getting similar mis-renderings in the Gigabyte support page.
In the beginning I couldn't even understand it was a flash until I loaded the same page in IE6...

BTW, here's the link for anyone interested:
http://ggts.gigabyte.com.tw/gtsemail.asp?LanguageID=1&UserEmail=

Comment 6

10 years ago
OK, after playing some more I finally figured it out.

The flash does appear, it's just that it's insanely small!!!
After zooming the hell out of it I was able to make it big enough to BARELY be recognizable.

BTW, I'm using WinXP SP2 w/Shockwave Flash 9.0 r115 in Firefox 3 Beta 4...

Comment 7

10 years ago
With reference to Comment #5

Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
http://www.adobe.com/products/flash/about/
You have version 9,0,115,0 installed

I just discovered that when I right-click on that swf and have it loaded into a new tab, then the swf gets played in full Tab/Window size.  

That's...: http://ggts.gigabyte.com.tw/images/in-logo.swf
with Titel: 
<OBJECT>, shockwave-flash@http://ggts.gigabyte.com.tw/images/in-logo.swf

Comment 8

10 years ago
(In reply to comment #7)I'm not sure how you did this.
When I right click I just get the shockwave menu (zoom in/out quality etc).

However when I follow the link you posted it uses the entire screen like you said.

That's with Firefox 3 beta 5 like you...

Comment 9

10 years ago
(In reply to comment #8)  (pertains as well to comment #2)

(1) I use the NoScript extension.  Thereby I have chosen to in general not allow Adobe Flash to be carried out without my explicit permission.  Thus, when I right click on the NoScript marker at which a Flach swf be located, I access the normal firefox context menu, which  offers the display of the object within a new tab or window.  Within that tab or window I can then left click to summon a NoScript dialog, by which I may temporarily allow its display.  

As for simply allowing the use of Adobe Flash at either of the two sites cited, when I do that then I presumably experience the same faulty display as you, Manos, and xpert lamer have described.  

(2) I also make use of the Web Developer 1.1.5 Extension, which makes it possible to list the various characteristics of the website I am viewing so as to better understand and evtlly document them. I was thus able to locate the single 1x1 pixel swf mentioned by xpert lamer via "Display Image Dimensions," which enabled me to right click it and then to load that swf into another tab.  
(Reporter)

Comment 10

10 years ago
(In reply to comment #4)
> WFM on XP, trunk. Shockwave Flash 9.0 r45
> and vista, trunk Shockwave Flash 9.0 r115
> 
> what is your version of flash?
> 

oops , that scrap i've posted as sample page was modified with no wmode parameter now.. anyway i don't remember exactly the version of my flash player (9.0.xxx maybe r115) at that time when i posted the problem, but as i wrote... with the VERY SAME flash player plugin with the very same machine, on the very same page and in that page the very same flash with wmode parameter was visible with FF2.x and ___was invisible with FF3 beta.x___ i don't know why? maybe the multiple tags of myspace or multiple embeds or multiple iterations of embedding or tags... who knows?
(Reporter)

Comment 11

10 years ago
(In reply to comment #9)
> (In reply to comment #8)  (pertains as well to comment #2)
> 
> (1) I use the NoScript extension.  Thereby I have chosen to in general not
> allow Adobe Flash to be carried out without my explicit permission.  Thus, when
> I right click on the NoScript marker at which a Flach swf be located, I access
> the normal firefox context menu, which  offers the display of the object within
> a new tab or window.  Within that tab or window I can then left click to summon
> a NoScript dialog, by which I may temporarily allow its display.  
> 
> As for simply allowing the use of Adobe Flash at either of the two sites cited,
> when I do that then I presumably experience the same faulty display as you,
> Manos, and xpert lamer have described.  
> 
> (2) I also make use of the Web Developer 1.1.5 Extension, which makes it
> possible to list the various characteristics of the website I am viewing so as
> to better understand and evtlly document them. I was thus able to locate the
> single 1x1 pixel swf mentioned by xpert lamer via "Display Image Dimensions,"
> which enabled me to right click it and then to load that swf into another tab.  
> 

nope :-(

the 1x1 pixel swf was (is) a completly different table on that page and (this is a streamed music) was NOTHING problem with it. the only problem was with the flash on the bottom of that page until i've reposted without the wmode parameter to avoid future problems with FF3...  i haven't used any kind of noscript or flashblock at that time on neither of those machines i wrote.
(Reporter)

Comment 12

10 years ago
(In reply to comment #5)
> With Firefox 3 beta 4 (Win XP) I'm getting similar mis-renderings in the
> Gigabyte support page.
> In the beginning I couldn't even understand it was a flash until I loaded the
> same page in IE6...
> 
> BTW, here's the link for anyone interested:
> http://ggts.gigabyte.com.tw/gtsemail.asp?LanguageID=1&UserEmail=
> 

this is a different kind of bug and as i see on FF2.0.0.13 too ...

my problem was the 400x400 pixel flash area was there, so i could right click there and i was able to get the standard Flash Player menu but the content was invisible for me, was simple white, instead of the funny Hitler-mustached boy... 
with all version of FF3 betas, and was right visible with all version of FF2 (!)

understand ?
(Reporter)

Comment 13

10 years ago
one more thing was interesting to me ... when i clicked there with either left or right button inside that flash area it looked like a selected gif or png with the dotted line around within a href tag...
(Reporter)

Comment 14

10 years ago
i don't think it's a big deal ... i better think it's a banal problem like multiple iterations of unfinished tags or something like that...
Severity: critical → normal

Comment 15

9 years ago
This is a problem also on bwin.com. With Firefox 3 RC2 I cannot place bets. When you login and bet on something, the box on the right side does not render correctly. I guess it's a problem with the coordinate translation, since the flash widgets don't even recive mouse events...
results with flash version 10?

Comment 17

9 years ago
Everything works fine for me now, Firefox 3.0.5 - Flash 10.0r12
=> WFM per comment 17. Thanks Manos
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.