add dateCreated and lastModifiedTime to the transaction service

RESOLVED FIXED in Firefox 3 beta3

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: dietrich, Assigned: dietrich)

Tracking

Trunk
Firefox 3 beta3
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

fix
10.40 KB, patch
(not reading, please use seth@sspitzer.org instead)
: review+
beltzner
: approval1.9+
Details | Diff | Splinter Review
(Assignee)

Description

10 years ago
Created attachment 291124 [details] [diff] [review]
fix
Attachment #291124 - Flags: review?(sspitzer)
Comment on attachment 291124 [details] [diff] [review]
fix

r=sspitzer

I think in nsPlacesTransactionsService.js
 we use both this.id and this._id.

I really wish we just did one, and I think this._id is the more common one.

We had bugs caused by mixing them up, and I think we even have a code clean bug about not doing this.id.

Can you use this._id instead?
Attachment #291124 - Flags: review?(sspitzer) → review+
(Assignee)

Updated

10 years ago
Target Milestone: --- → Firefox 3 M11

Updated

10 years ago
Blocks: 401166
(Assignee)

Comment 2

10 years ago
the id is modified externally for nested transactions, so we should probably standardize on .id instead of ._id.
(Assignee)

Comment 3

10 years ago
> We had bugs caused by mixing them up, and I think we even have a code clean bug
> about not doing this.id.
> 

bug 390007
(Assignee)

Comment 4

10 years ago
Comment on attachment 291124 [details] [diff] [review]
fix

drivers: blocking a blocker.
Attachment #291124 - Flags: approval1.9?
Comment on attachment 291124 [details] [diff] [review]
fix

a=beltzner for 1.9
Attachment #291124 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

10 years ago
Blocks: 393498
(Assignee)

Comment 6

10 years ago
Checking in browser/components/places/content/utils.js;
/cvsroot/mozilla/browser/components/places/content/utils.js,v  <--  utils.js
new revision: 1.92; previous revision: 1.91
done
Checking in browser/components/places/public/nsIPlacesTransactionsService.idl;
/cvsroot/mozilla/browser/components/places/public/nsIPlacesTransactionsService.idl,v  <--  nsIPlacesTransactionsService.idl
new revision: 1.9; previous revision: 1.8
done
Checking in browser/components/places/src/nsPlacesTransactionsService.js;
/cvsroot/mozilla/browser/components/places/src/nsPlacesTransactionsService.js,v  <--  nsPlacesTransactionsService.js
new revision: 1.11; previous revision: 1.10
done
Checking in browser/components/places/tests/unit/test_placesTxn.js;
/cvsroot/mozilla/browser/components/places/tests/unit/test_placesTxn.js,v  <--  test_placesTxn.js
new revision: 1.13; previous revision: 1.12
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Flags: in-testsuite+
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.