Closed Bug 406482 Opened 13 years ago Closed 13 years ago

Canvas: drawImage() doesn't work after update

Categories

(Firefox :: General, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 405584

People

(Reporter: mansuriqbal, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10

Canvas: drawImage() doesn't work after update to on 2.0.0.10
it throws always:
uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMCanvasRenderingContext2D.drawImage]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: file:///C:/Dokumente%20und%20Einstellungen/Fabi/Desktop/canvas.html :: juhu :: line 10" data: no]

Reproducible: Always

Steps to Reproduce:
1.create a canvas
2.load an image into an imageobject
3.try to draw this object with drawImage()
or see for example: http://developer.mozilla.org/samples/canvas-tutorial/3_2_canvas_drawimage.html
Actual Results:  
nothing. firebug shows an error.

Expected Results:  
it should show an image!

ie is the best, **** the rest.
Update to 2.0.0.11; it contains a fix.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 405584
You need to log in before you can comment on or make changes to this bug.