Download Manager stuck scanning for viruses

VERIFIED DUPLICATE of bug 401582

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 401582
10 years ago
10 years ago

People

(Reporter: Jason Gurley, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

The download manager is stuck scanning for viruses on a file.  This file in particular no longer exists (it didn't have a virus, I just accidentally downloaded it and didn't need it, so I deleted it).  There is no option to clear or cancel the scan.  I have tried replacing the file, no luck, it still is in perpetual scanning mode.

Reproducible: Didn't try

Steps to Reproduce:
I don't know how it happened in the first place.
Actual Results:  
It should go away.

Expected Results:  
It is still there.
(Reporter)

Comment 1

10 years ago
There SHOULD be a way to cancel the scan when things like this happen.  Instead, the only right-click option is "Copy Source Location".  So I'm stuck with this "scanning for viruses" on index.php in the download manager and no way to get rid of it.
It's not actually scanning - the database just didn't get updated...

We will never offer the option to cancel a scan since we can't actually cancel it anyway...
(Reporter)

Comment 3

10 years ago
Is there any way to remove it from the list?  I'm getting tired of looking at it...

Comment 4

10 years ago
I just got the same problem. Steps to reproduce:
1. Download a file
2. At the moment scanning happens, kill/crash your firefox

Expected results: the file is marked as complete at next startup

Actual results: the file remains in "scanned" state forever. There is no way for mortals to do something about it. The thing animates until people scream.

Comment 5

10 years ago
Created attachment 291436 [details]
downloads.sqlite with such stuck file.

You might need to download something or else list remains empty, somehow.

Updated

10 years ago
Version: unspecified → Trunk

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401582
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.