Add-on update shows incorrect version while downloading extension

RESOLVED DUPLICATE of bug 340219

Status

()

Toolkit
Add-ons Manager
--
trivial
RESOLVED DUPLICATE of bug 340219
10 years ago
9 years ago

People

(Reporter: Nobuyuki Sakamoto, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

When an update to an extension is available, the old and new version numbers are shown on the selection dialog.  After approving such extensions, the dialog showing the download progress shows the old version number, rather than the new number.

This happens with Firefox on Mac OS X, Ubuntu, and Windows, as well as Thunderbird.

Reproducible: Always

Steps to Reproduce:
1.  Receive notification of an update to an extension.
2.  Approve the download.
3.  Check the version number while the extension is being downloaded.
Actual Results:  
Old version number is shown while downloading, even though new version is actually downloaded.

Expected Results:  
New version should be reported as being downloaded.

This happens both with Firefox and Thunderbird.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 340219
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.