Closed Bug 406528 Opened 13 years ago Closed 13 years ago

if a page has no title (including a redirect) we need to clear the previous title

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta4

People

(Reporter: moco, Assigned: mak)

References

Details

Attachments

(2 files)

if a page has no title or is a redirect, we need to clear the previous title

this bug comes in a few flavors:

a)

1) page doesn't exist, so you get a 404 title (like "www.sspitzer.org Error page" for http://www.sspitzer.org/foobarcheese.html)
2) then, I create that page, but I don't give it a title

in moz_places, we continue to use "www.sspitzer.org Error page".  that will show up in in url bar autocomplete, places organizer, history sidebar, etc.

b) a site that normally redirects, like mail.polvi.net is temporarily down, so you get a 5xx message.  when it comes back, the title remains bogus (see screen shot.)
Summary: if a page has no title or is a redirect, we may need to clear the previous title → if a page has no title (including a redirect) we need to clear the previous title
hmm, I'm not 100% certain that what polvi is seeing (case b) is the same as what I can reproduce (case a), but both are bugs.
Also, if you 401 on a file... then get it later... the title will still be a 401 if the page has no title. 
If the title of a page changes we should always update it -- even if it means updating to a blank title. 

Consider this example, gmail.com redirects to mail.google.com. If just one time gmail.com is a 404 when the user hits it, it will always be "404 not found" because the properly working redirect has a blank title. This is inconsistent and misleading.
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attached patch patchSplinter Review
made so if the title is empty we nullify it, and fixed some wrong check i've found in nsNavHistory title related functions
Attachment #303506 - Flags: review?(dietrich)
Comment on attachment 303506 [details] [diff] [review]
patch

r=me, thanks for the fix and the cleanup.
Attachment #303506 - Flags: review?(dietrich) → review+
Target Milestone: --- → Firefox 3 beta4
Checking in toolkit/components/places/src/nsNavHistory.cpp;
/cvsroot/mozilla/toolkit/components/places/src/nsNavHistory.cpp,v  <--  nsNavHistory.cpp
new revision: 1.251; previous revision: 1.250
done
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Verified with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042906
Minefield/3.0pre
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.