Closed Bug 406551 Opened 14 years ago Closed 13 years ago

Search, Index and Glossary tabs are missing

Categories

(SeaMonkey :: Help Documentation, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0b1

People

(Reporter: hand_of_fate2000, Assigned: InvisibleSmiley)

References

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007113002 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007113002 SeaMonkey/2.0a1pre

In previous SeaMonkey releases the sidebar in the Help Viewer has four tabs: "Contents", "Search", "Index" and "Glossary". In the latest trunk the "contents" tab is permanently displayed, and all the other tabs are missing.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008041601 SeaMonkey/2.0a1pre

There is a search box at the right end of the toolbar (which has the "Back, "Forward", "Help Start Page" and "Print" buttons at the left end). I suspect that that search box will function as Search, Index and Glossary but I haven't tried. Ed, what do you think?
Keywords: regression
Version: unspecified → Trunk
Assignee: neil → nobody
QA Contact: danielwang → help
I don't know if we still need Search, Index and Glossary tabs but they are mentioned on the Help start page (that appears when you press F1) so either way action is needed, thus confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
IMO we don't need/want them. Also, we're use the toolkit Help Viewer and it doesn't use these tabs.
Attached patch proposed patch (obsolete) — Splinter Review
The attached patch stops referring to the removed four tabs and instead points the user toward the search box in addition to the left frame (Contents). The Glossary is linked now because you cannot find it through the search. I didn't find a way to refer to the index, though. Maybe we should discuss its fate in another bug.

I also changed the IRC link from #mozillazine to #seamonkey and updated the link under User Feedback (QFA is gone and the old link redirects to the new one).
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #369847 - Flags: review?(stefanh)
I won't be able to look at this until the end of next week. Re the link to the seamonkey channel: KaiRo - do we want this?
I think we can link #seamonkey nowadays, yes, people are coming there for end user support anyway.
Comment on attachment 369847 [details] [diff] [review]
proposed patch

>diff --git a/suite/locales/en-US/chrome/common/help/welcome_help.xhtml b/suite/locales/en-US/chrome/common/help/welcome_help.xhtml
>--- a/suite/locales/en-US/chrome/common/help/welcome_help.xhtml
>+++ b/suite/locales/en-US/chrome/common/help/welcome_help.xhtml
>@@ -12,25 +12,19 @@
> <link rel="stylesheet" href="helpFileLayout.css"
>   type="text/css"/>
> </head>
> <body>
> 
> <h1>Welcome to &brandShortName; Help</h1>
> 
> <p>To display information about &brandShortName; in this window, <strong>click
>-  tabs or topics in the left frame</strong>:</p>
>-
>-<ul>
>-  <li><strong>Contents</strong> shows main topics and subtopics.</li>
>-  <li><strong>Search</strong> lets you search built-in &brandShortName;
>-    Help.</li>
>-  <li><strong>Index</strong> lists all topics alphabetically.</li>
>-  <li><strong>Glossary</strong> defines key terms.</li>
>-</ul>
>+  topics in the left frame</strong> or <strong>use the search box above</strong>.
>+  To learn about key terms used in these documents, refer to the <strong><a
>+  href="glossary.xhtml">Glossary</a></strong>.</p>

Basically, this page exists so users can get a welcome page with additional links. I don't think we want to link to the glossary here - it's really enough to say "To display information about SeaMonkey in this window, click topics in the left sidebar."


>   <tr valign="top">
>     <td colspan="2"><h2>User Feedback</h2></td>
>   </tr>
>   <tr>
>     <td>
>-      <p><strong><a href="http://www.mozilla.org/quality/qfa.html">Quality
>-        Feedback Agent</a></strong></p>
>+      <p><strong><a href="https://developer.mozilla.org/en/Crash_reporting">Crash
>+        reporting</a></strong></p>


I wonder why that link is there. The thing is that this is not really user feedback - it wasn't that before either, of course. The information is on devmo, so it's really developer-oriented. And as a user I'd expect a page where I can enter feedback - at least that's what the title "User Feedback" sounds like. Maybe we should remove the whole section?
Attachment #369847 - Flags: review?(stefanh) → review-
(In reply to comment #7)
> I don't think we want to link to the glossary here - it's really enough
> to say "To display information about SeaMonkey in this window, click topics in
> the left sidebar."

The point is that currently the glossary (and the index, if I'm not wrong) isn't accessible directly anymore. It used to be a sidebar tab but with the new Toolkit dialog our possibilities are limited:

a) add a link to the welcome page like I did
b) add it to the index used by the search function (which file is used for that?)
c) add it to the default content (tree) of the sidebar (suite-toc.rdf I guess)

I understand that you don't want to distract people by including it on the welcome page but I think it needs to be accessible in some way, not just by #anchor links directing at it. I think we should go for options b+c for Glossary but I don't know about Index (it seems it's RDF while all the other pages are XHTML, does that make a difference?).

In any case I'd like to keep the "or use the search box above" part of my proposal since searching can be the quicker way to view the results you're heading for (I'm OK with changing "frame" to "sidebar", though). What do you think?

>> [User Feedback]
> Maybe we should remove the whole section?

No objections from me here.
(In reply to comment #8)
> (In reply to comment #7)
> > I don't think we want to link to the glossary here - it's really enough
> > to say "To display information about SeaMonkey in this window, click topics in
> > the left sidebar."
> 
> The point is that currently the glossary (and the index, if I'm not wrong)
> isn't accessible directly anymore. It used to be a sidebar tab but with the new
> Toolkit dialog our possibilities are limited:
> 
> a) add a link to the welcome page like I did
> b) add it to the index used by the search function (which file is used for
> that?)
> c) add it to the default content (tree) of the sidebar (suite-toc.rdf I guess)
>

We already do b) so you can search for glossary terms. Do we expect users to browse the glossary (if a word/subject is in content we should link to the explanation in the glossary imo)?


> I understand that you don't want to distract people by including it on the
> welcome page but I think it needs to be accessible in some way, not just by
> #anchor links directing at it. I think we should go for options b+c for
> Glossary but I don't know about Index (it seems it's RDF while all the other
> pages are XHTML, does that make a difference?).

The thing is that we already describe how to navigate/show topics and how to search for them in "Using the Help Window" - and we link to that page from welcome_help (just ater the sentense you're changing). Personally, I feel that we shouldn't have multiple/similar content in different places - it's hard to maintain (probably one of the reasons why this bug exists).

The problem here could be that we don't start by describing how to use help, so
another option would be to use the toolkit welcome page  (there's actually a bug for it) and put the seamonkey "Help Center" page after the toolkit welcome page.
(In reply to comment #8)
> (In reply to comment #7)

> In any case I'd like to keep the "or use the search box above" part of my
> proposal since searching can be the quicker way to view the results you're
> heading for (I'm OK with changing "frame" to "sidebar", though). What do you
> think?

I'm not convinced, but if you still think it's reasonable - sure. Note that searching for topics doesn't imply that they're displayed in the content window, though
Attached patch welcome/toc v2 (obsolete) — Splinter Review
(In reply to comment #9)
> Do we expect users to
> browse the glossary (if a word/subject is in content we should link to the
> explanation in the glossary imo)?

I don't know what the average user does, I'm not using Help myself (maybe I briefly did in the beginning). I think we should support any valid entry path, though. Currently you cannot reach the Glossary directly. By adding it to the sidebar we get two things at once: it's listed in the Contents sidebar and can even be found using the search field. That's what I did in my new patch.

> The thing is that we already describe how to navigate/show topics and how to
> search for them in "Using the Help Window" - and we link to that page from
> welcome_help (just ater the sentense you're changing).

On second thought I agree now that we shouldn't use the welcome page for that so I removed it in my new patch.

As far as Index is concerned I'd say let's just remove it completely (including all its files), it doesn't really fit the new Help window anymore (which is basically Contents sidebar + main pane + search, with sidebar and search closely coupled). We could do that in this bug or a new one but in any case I'd prefer to do it in a separate patch.

> The problem here could be that we don't start by describing how to use help, so
> another option would be to use the toolkit welcome page  (there's actually a
> bug for it) and put the seamonkey "Help Center" page after the toolkit welcome
> page.

As you said that's another bug, thus out of scope here. This bug is mainly about making Help contents consistent with the removal of the sidebar tabs. Let's make one step at a time.

> (In reply to comment #8)
> Note that searching for topics doesn't imply that they're displayed in the
> content window, though

Good point. After rethinking I came to the conclusion that searching is pretty self-explanatory and removed the part about "the search box above".
Attachment #369847 - Attachment is obsolete: true
Attachment #372676 - Flags: review?(stefanh)
I am tempted to still mention "the search box above"
I would put links to the glossary and index (if kept) on the welcome page.
Again I would put Glossary (and index) into the TOC.

A side note when searching for "identify" in the search box you get some interesting results - outside scope of course but probably needs fixing.
Comment on attachment 372676 [details] [diff] [review]
welcome/toc v2

 <p>To display information about &brandShortName; in this window, <strong>click
-  tabs or topics in the left frame</strong>:</p>
-
-<ul>
-  <li><strong>Contents</strong> shows main topics and subtopics.</li>
-  <li><strong>Search</strong> lets you search built-in &brandShortName;
-    Help.</li>
-  <li><strong>Index</strong> lists all topics alphabetically.</li>
-  <li><strong>Glossary</strong> defines key terms.</li>
-</ul>
+  topics in the sidebar on the left</strong>.</p>

I was going to suggest "click topics in the sidebar on the left", but after some discussion with IanN I think "click topics in the lefthand sidebar" is better.

r=me with the above nit fixed.
Attachment #372676 - Flags: review?(stefanh) → review+
(In reply to comment #13)
> I was going to suggest "click topics in the sidebar on the left", but after
> some discussion with IanN I think "click topics in the lefthand sidebar" is
> better.

I'm not a native speaker (and neither are you I guess) but "lefthand" looks wrong to me, I think it should either be "left hand", "left hand side" (possibly clashes with "sidebar") or my "on the left". Ian?

Regarding comment 12, did your discussion with Ian already include the points he made?

@Ian: The "identify" matches are the Contents sidebar entries under Using Certificates/Managing Certificates. They could be changed as part of bug 459566 or we could open a separate one for just renaming the entries, whatever you prefer.
(In reply to comment #14)
> (In reply to comment #13)
> > I was going to suggest "click topics in the sidebar on the left", but after
> > some discussion with IanN I think "click topics in the lefthand sidebar" is
> > better.
> 
> I'm not a native speaker (and neither are you I guess) but "lefthand" looks
> wrong to me, I think it should either be "left hand", "left hand side"
> (possibly clashes with "sidebar") or my "on the left". Ian?

Sources tells me that it should be "left-hand".
> 
> Regarding comment 12, did your discussion with Ian already include the points
> he made?

Yes (forgot to mention it).

> 
> @Ian: The "identify" matches are the Contents sidebar entries under Using
> Certificates/Managing Certificates. They could be changed as part of bug 459566
> or we could open a separate one for just renaming the entries, whatever you
> prefer.
(In reply to comment #14)
> (In reply to comment #13)
> @Ian: The "identify" matches are the Contents sidebar entries under Using
> Certificates/Managing Certificates. They could be changed as part of bug 459566
> or we could open a separate one for just renaming the entries, whatever you
> prefer.
Yeah in that bug seems a logical place.
Attachment #372676 - Attachment is obsolete: true
Attachment #375776 - Flags: review+
Keywords: checkin-needed
I pushed attachment #375776 [details] [diff] [review] to comm-central as http://hg.mozilla.org/comm-central/rev/2eb93bb53c53. Unfortunately, I messed up the -u option, so Jens didn't got any credit for the patch :(

I've tried to correct this in another changeset: http://hg.mozilla.org/comm-central/rev/83e09049bbc6. Sorry for this.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0b1
Keywords: checkin-needed
Blocks: 423281
Duplicate of this bug: 461725
You need to log in before you can comment on or make changes to this bug.