Closed Bug 406554 Opened 14 years ago Closed 14 years ago

PNG background image looks corrupted

Categories

(Core :: ImageLib, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 403423

People

(Reporter: twentyafterfour+bz, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

planet.gnome.org background png looks corrupted (black with vertical colored lines)

Reproducible: Always

Steps to Reproduce:
1. open firefox 3 beta 1
2. visit planet.gnome.org
3. observe strange corrupted visuals
Actual Results:  
background image looks corrupted 

Expected Results:  
image not corrupted

I'm using a gnome desktop (Ubuntu Guttsy) and this happens with or without Compiz running.

Does not happen with firefox 2.
Attached image screenshot of problem
I can reproduce this under Linux, but not under Windows.  Moving to more correct component and confirming.
Status: UNCONFIRMED → NEW
Component: General → ImageLib
Ever confirmed: true
Product: Firefox → Core
Version: unspecified → Trunk
QA Contact: general → imagelib
Flags: blocking1.9?
I can reproduce this on Windows Vista.

The pattern seem to be random, but always similar to the attachment. It changes when I clear cache and reload, and seemingly randomly at other times.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007120205 Minefield/3.0b2pre ID:2007120205
This is a regression from the check-in for bug 395170.

This was verified via backout.
Blocks: 395170
Keywords: regression
Dup of bug 403423?
Dup - patch from bug 403423 fixes this.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403423
You need to log in before you can comment on or make changes to this bug.