Make places toolbar items behave like a menu

RESOLVED DUPLICATE of bug 397111

Status

()

RESOLVED DUPLICATE of bug 397111
11 years ago
9 years ago

People

(Reporter: micmon, Assigned: martijn.martijn)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

11 years ago
Press "Organize" in Places Organizer. A menu will show up. Drag the mouse to the right. I would expect "Views" to pop up now, but this does not happen.
(Assignee)

Comment 1

11 years ago
Created attachment 291343 [details] [diff] [review]
patch

This makes it work for me. I basically copied this from bug 203556.
Attachment #291343 - Flags: review?

Comment 2

11 years ago
this is related to UI, adding uiwanted, someone should tell what's expected behaviour
Keywords: uiwanted
Assignee: nobody → martijn.martijn
Attachment #291343 - Flags: review? → review?(mano)
(In reply to comment #2)
> this is related to UI, adding uiwanted, someone should tell what's expected
> behaviour

I don't think UX help is needed here, as it's clearly buggy. The expected behavior would be to act like all the rest of the menus instead of doing something dumb. However, I could be wrong.
Status: NEW → ASSIGNED

Comment 4

11 years ago
yes, i also think that it should work like that, but this is still a toolbar and not a real menu
(Reporter)

Comment 5

11 years ago
Sure (but why?). 

Folders (Containers) on the bookmark toolbar seem to be the same, technically (toolbar buttons). Andy they work similar to menus, too. 
(Assignee)

Comment 6

11 years ago
It's a toolbar type="menu", no?

Comment 7

11 years ago
See also bug 397111 which is a dupe.  But this has a patch and that has blocking so I'm not sure which to keep.  

Comment 8

11 years ago
clearing uiwanted, since that bug has a blocking status from beltzner the patch should be posted there
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: uiwanted
Resolution: --- → DUPLICATE
Duplicate of bug: 397111
Attachment #291343 - Attachment is obsolete: true
Attachment #291343 - Flags: review?(mano)
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.