expanding a Folder in Places' left Pane is broken

VERIFIED INVALID

Status

()

Firefox
Bookmarks & History
VERIFIED INVALID
10 years ago
8 years ago

People

(Reporter: xtc4uall, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
since landing of Bug 387746 opening places, collapsing e.g. 'All Bookmarks' and trying to expand it afterwards fails.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007120305
(new profile etc.)
Flags: blocking-firefox3?
WFM Vista HP

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007120306 Minefield/3.0b2pre Firefox/3.0 ID:2007120306
(Reporter)

Comment 2

10 years ago
ok,
maybe one additional step before:
- in places, drag bookmarks toolbar folder
- drop it in the right pane at some white place
-> it's duplicated now (another bug?)
- collapse 'All Bookmarks' in left pane
- try to expand 'All Bookmarks' in left pane
The duplication is a bug Seth Spitzer filed a few days ago.

Comment 4

10 years ago
duplication is Bug 406089

while not being able to expand All bookmarks is likely due to the lack of one of the roots, that is caused by bad duplication behaviour... so i think that this can be marked as dupe (or depend) of Bug 406089
(Reporter)

Comment 5

10 years ago
i'll check this bug asap as Bug 406089 is fixed and mark this WFM
Depends on: 406089
Flags: blocking-firefox3?
(Reporter)

Comment 6

10 years ago
sorry, but fixing Bug 406089 did not fix it :-/
i fear that my places.sqlite file got somehow corrupt.
if i do above STR with an imported bookmarks file created some time before (actually for usage in FF2), the bug doesn't appear.
it only applies with my places.sqlite which grew with every nightly build since re-enabling places on trunk.
so the only solution would be to export my places.sqlite to bookmarks, loose all history and re-import.
the same applies to Bug 406599 which i discovered after this.

Comment 7

10 years ago
well the patches will not be able to restore your places atm, they should avoid that you can fall into such a situation... the problem is that you have lost one of the roots (bookmark menu, toolbar, unfiled bookmarks) and there is no easy path to restore only missing one (but direct editing of places db)

now bookmarks.postplaces.html is still not imported.
notice that Bug 406089 is still not fixed
Does this issue still exist or can we close this bug?
Target Milestone: Firefox 3 → ---

Comment 9

10 years ago
i mark this as INVALID (not valid actually really) because the situation was caused by other previous bugs that allowed the user to remove a root causing a db corruption. Actually this should not happen anymore.

There are no easy paths to recover from such a situation, probably an extension could try to save the db by directly accessing the datas and fixing tables contents.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
Hardware: PC → All
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.