switch url-classifier unit tests to use hash-encoded data

RESOLVED DUPLICATE of bug 750751

Status

()

Toolkit
Safe Browsing
P3
normal
RESOLVED DUPLICATE of bug 750751
11 years ago
a year ago

People

(Reporter: dcamp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Right now the url-classifier unit tests use plaintext urls when populating the database, which uses a different codepath in nsUrlClassifierDBServiceWorker::GetChunkEntries().

We should change the unit tests to feed data in the hashed format used by the protocol.
I couldn't agree more: the fact that all tests are using a different codepath from the production code is one of the most annoying issues with the current (and new!) SB code, an additional complication, a cause of bugs, and a cause of codebloat.
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
Priority: -- → P2
Whiteboard: tpe-seceng
Assignee: nobody → tnguyen

Updated

2 years ago
Assignee: tnguyen → nobody
Priority: P2 → P3
Whiteboard: tpe-seceng
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 750751
You need to log in before you can comment on or make changes to this bug.