Closed Bug 406704 Opened 12 years ago Closed Last year

.autocomplete-richlistbox does not allow a background image

Categories

(Firefox :: Address Bar, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED INACTIVE

People

(Reporter: ehume, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007120305 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007120305 Minefield/3.0b2pre

When this code is inserted into popup.css, the scrollbar in the autocomplete dropdown panel does not move the menuitems:

panel {background-image: url('chrome://global/skin/F.gif') !important;}

Commenting out this line restores normal function of the scrollbars and menuitems; but this means the richlist autocomplete results cannot be skinned.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



See Mozillazine forum http://forums.mozillazine.org/viewtopic.php?t=608961

for details, along with some images that shows the bug in action.
Confirmed on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007120408 Minefield/3.0b2pre, scrolling does not move the list.

Weird is, and I don't know if it is related, that also without this code my scrollbar sticks for a second to top or bottom if I want to scroll; it looks like a sort of delay. When I drag the scrollbar, I see the autocomplete list move, but the scrollbar has delay. Maybe it's just my computer.
Blocks: 399664
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #1)
> Weird is, and I don't know if it is related, that also without this code my
> scrollbar sticks for a second to top or bottom if I want to scroll; it looks
> like a sort of delay. When I drag the scrollbar, I see the autocomplete list
> move, but the scrollbar has delay. Maybe it's just my computer.

I think that's part of the "new autocomplete is slow". (haven't seen a bug about it, though)

CatThief has come up with work-arounds. I posted them on the Mozillazine thread.
Please mark this bug as resolved - invalid. There is no longer any need to fix this.
invalid, per ed's comment #4
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
I hate to say this, but our work-arounds do not work except in limited circumstances. So, this bug is not invalid. I would like to request that we un-resolve it.

I was able to get a work-around using a 17x4-pixel image that tiles both vertically and horizontally. However, using an image that does not tile vertically (it is larger than the richlistitem) the problem returns. For one user on the forum thread - mcdavis941 - the problem was never resolved.

I will post an example of a theme that continues to cause the problem.
The theme that shows the problem is here:

http://www.pshrink.com/firebird/scribbliesbrite-2.3-fx.jar

Also: could this bug be related to the menulist bug, #408955?
The theme shows the problem and is visible since bug 403159 was fixed.
Looks indeed very similar to bug 408955.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Version: unspecified → Trunk
FWIW I'm still seeing this too.  Screenshot shows the open URL bar autocomplete with improper rendering at top and bottom, which shows up when you start using the scrollbar.  With NNL 0.6.20080226:

https://addons.mozilla.org/en-US/firefox/addon/4908
Per policy at https://wiki.mozilla.org/Bug_Triage/Projects/Bug_Handling/Bug_Husbandry#Inactive_Bugs. If this bug is not an enhancement request or a bug not present in a supported release of Firefox, then it may be reopened.
Status: REOPENED → RESOLVED
Closed: 12 years agoLast year
Resolution: --- → INACTIVE
You need to log in before you can comment on or make changes to this bug.