document.clear and document.open('text/html','replace')

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Gerd Kortemeyer, Assigned: jst)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
document.clear and document.open('text/html','replace') do not clear the
respective window or frame. Instead, text written out with document.write(ln)
afterwards gets appended to the already existing content.

The script at http://zaphod.lite.msu.edu/adm/rat/code.html runs fine on both
Netscape and Internet Exploder.
(Assignee)

Comment 1

18 years ago
This bug has been marked "future" because the original netscape engineer
working on this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work
in some way -- please attach your concern to the bug for reconsideration.
Target Milestone: --- → Future

Comment 2

18 years ago
confirmed, dont see image in mozilla also
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

17 years ago
Maybe I'm stupid, but I don't see any difference in the way the above site works
in NS4.x, IE 5.5 and a current mozilla build. Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
Verified with 2001-020608.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.