updater loop, similar to bug 351369, XML parsing error, Software update failed

RESOLVED DUPLICATE of bug 340535

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 340535
11 years ago
10 years ago

People

(Reporter: stuckee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

49.01 KB, application/octet-stream
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10
Build Identifier: 2.0.0.8? (can't verify, thunderbird is dead)

I have admin privileges, have been using mozilla since phoenix 1.0 and have done many upgrades/updates successfully...until now.

Got the notice of thunderbird update 2.0.0.9; thunderbird was open at the time, chose to install the update and think I closed the thunderbird mail screen as the update downloaded.  I managed to get some notes:

XML Parsing Error: not well-formed
Location: chrome://mozapps/content/update/updates.xul
Line Number 1, Column 7:hrome://mozapps/locale/update/updates.dtd">

restarted thunderbird

Software Update Failed
One or more files could not be updated.  Please make sure all other applications are closed and that you have permission to modify files, and then restart thunderbird and try again.

closed all the open windows I could find (a software update window was hiding, cancelled it)

restarted thunderbird and mail screen came up OK

check for updates again via help 

Update Failed
The partial update could not be applied.  Thunderbird will try again by downloading a complete Update.

(downloaded 8.1M file, allowed it to update)

Software Update Failed
One or more files could not be updated.  Please make sure all other applications are closed and that you have permission to modify files, and then restart thunderbird and try again.

software update
Thunderbird is installing your updates and will start in a few moments

Software Update Failed
One or more files could not be updated.  Please make sure all other applications are closed and that you have permission to modify files, and then restart thunderbird and try again.

killed thunderbird as thoroughly as I could with Process Explorer (sysinternals)

tried to restart thunderbird, was unsuccessful

Software Update Failed
One or more files could not be updated.  Please make sure all other applications are closed and that you have permission to modify files, and then restart thunderbird and try again.

---------------

At this point, thunderbird is toast...it will not come up at all, just loops between the 'software update' / 'software update failed' message screens.  Thunderbird has two email accounts and I set both to NOT automatically check for new mail earlier today (does it matter? I don't know) because of some unrelated webmail/thunderbird synchronization problems; the configuration is many months old but the mail setting is new.

Reproducible: Always

Steps to Reproduce:
1.thunderbird will not come up at all, just loops
2.
3.
Actual Results:  
Thunderbird loops; see details section

Expected Results:  
I'm guessing that the update is only partially installed; may or may not be related to closing (I think) thunderbird while the updater was downloading, don't remember for sure.  In the meantime, it seems to be stuck in a loop as it recognizes the need for an update but cannot install it.

I think my only choice is to totally reinstall thunderbird.  However, I'll wait a couple of days in case the error messages are helpful or I can get any other information.  If no one contacts me, I'll POR (power on reset) and see if that changes anything.  If that fails, the only thing left is to reinstall.

Comment 1

11 years ago
Probably bug 340535 (and/or server hiccups). And yeah, I think you will have to do the manual full reinstall.

Comment 2

11 years ago
Hi!

I got this message in every updates.
I'm sysadmin, so this is not right problem!

I use update function manually, but same thing happened. In Safe mode also.
This is cyclyc thing, so if I terminate tdb process, and I try to start, i got same error.

Only thing I can do that I delete the Update dir fully. After this the tdb download the full package. But this is very hateable error.

Comment 3

11 years ago
Created attachment 299126 [details]
The log of the update
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 340535
You need to log in before you can comment on or make changes to this bug.