Closed Bug 406840 Opened 14 years ago Closed 14 years ago

NoScript 1.1.8 leaks every toplevel document loaded since nsDocument::Destroy landing

Categories

(Core :: DOM: Core & HTML, defect, P1)

x86
Linux
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: dbaron, Assigned: peterv)

References

Details

(Keywords: memory-leak, regression)

This is a regression between 2007-11-30-04-trunk and 2007-12-01-04-trunk Linux nightlies, presumably due to bug 348156.

Steps to reproduce:
  1. install **version 1.1.8** of the NoScript extension from https://addons.mozilla.org/en-US/firefox/addons/versions/722 .  DO NOT install the newer version 1.1.8.3, since it has a regression that causes a similar leak on builds before the regression described in this bug.
  2. set up leak-gauge, as described in http://mxr.mozilla.org/seamonkey/source/tools/footprint/leak-gauge.pl?raw=1
  3. run Firefox with the environment variables document in leak-gauge.pl to load http://www.google.com/ and then close the window

Actual results: 4 windows (inner and outer for the hidden window, inner and outer for google.com) and 1 document (google.com) leaked

Expected results: 2 windows (for the hidden window) leaked
Flags: blocking1.9?
Summary: NoScript 1.1.8 leaks every toplevel document loaded → NoScript 1.1.8 leaks every toplevel document loaded since nsDocument::Destroy landing
This should have been fixed by the patch in bug 406684.

David, are you still seeing this?
Depends on: 406684
+ing in case this isn't fixed by bug 406684
Flags: blocking1.9? → blocking1.9+
Priority: -- → P1
Works for me in a Linux debug build pulled at 8:30am this morning.
Assignee: nobody → peterv
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.