selecting a text inside a LRO (left to right override) text block with the electing a text inside a LRO (left to right override) text block with the mouse is messy

RESOLVED DUPLICATE of bug 332486

Status

()

RESOLVED DUPLICATE of bug 332486
11 years ago
11 years ago

People

(Reporter: gangleri, Unassigned)

Tracking

({rtl})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.3) Gecko/20070427 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.3) Gecko/20070427 Firefox/2.0.0.3

I copy the details here as well:

Posting a separate comment in order to open a new bug regarding strange text
selection with the the mouse which relates in *no* way to the position of the
curser moving over the text.

a‭באַניצער:לערי ריינהארט/tests/bugzilla – װיקיװערטערבוך‬z

aבאַניצער:לערי ריינהארט/tests/bugzilla – װיקיװערטערבוךz

Best regards Reinhardt [[user:Gangleri]]

Reproducible: Always

Steps to Reproduce:
1) position the cursor on top of the second BiDi line;
2) click on the mouse button and hold it pressed
3) move the mouse / cursor to the left or to the right
4) please compare in what direction area the characters are selected
(Reporter)

Comment 1

11 years ago
Remedy:  It is possible to click at a location and mark the text having the Shift-key pressed and using arrow keys. This selects the text in a LRO (left to right override) text block as supposed.


Trying to insert here a multiline LRO (left to right override) text block:

----
aבאַניצער:לערי ריינהארט/tests/bugzilla
Remedy:  It is possible to click at a location and mark the text having the Shift-key pressed and using arrow keys. This selects the text in a LRO (left to right override) text block as supposed.
באַניצער:לערי ריינהארט/tests/bugzilla –
----

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 332486

Comment 3

11 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.