check for widget destruction after sending events in scrollwheel and flagsChanged event handlers

RESOLVED DUPLICATE of bug 402505

Status

()

Core
Widget: Cocoa
P4
normal
RESOLVED DUPLICATE of bug 402505
10 years ago
10 years ago

People

(Reporter: Josh Aas, Assigned: Josh Aas)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
Created attachment 291598 [details] [diff] [review]
fix v1.0

We should check for widget destruction after sending events in scrollwheel and flagsChanged event handlers.
Flags: blocking1.9+
Attachment #291598 - Flags: review?(smichaud)
(Assignee)

Updated

10 years ago
Priority: -- → P4
(Assignee)

Comment 1

10 years ago
Comment on attachment 291598 [details] [diff] [review]
fix v1.0

This already has r+ from smichaud on bug 402505.
Attachment #291598 - Flags: review?(smichaud) → superreview?(roc)

Comment 2

10 years ago
bug 402505 will address this, and more. (please don't check this in -
it will just give me a cvs conflict).
(Assignee)

Comment 3

10 years ago
Comment on attachment 291598 [details] [diff] [review]
fix v1.0

That patch is already rotted, lets just land this and be done with this particular bug.
Attachment #291598 - Flags: superreview?(roc)

Comment 4

10 years ago
(In reply to comment #3)
> That patch is already rotted, lets just land this and be done with this
> particular bug.

I've updated it to tip, let's review and land the patch in bug 402505 instead.
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 402505
You need to log in before you can comment on or make changes to this bug.