Dropping an URL onto the tabbar no longer opens it in a new tab

VERIFIED FIXED in Firefox 3 beta2

Status

()

Firefox
Tabbed Browser
P2
normal
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: stevee, Assigned: dietrich)

Tracking

({regression})

Trunk
Firefox 3 beta2
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

fix
884 bytes, patch
(not reading, please use seth@sspitzer.org instead)
: review+
mconnor
: approvalM10+
Details | Diff | Splinter Review
1.22 KB, patch
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2pre) Gecko/2007120319 Minefield/3.0b2pre ID:2007120319

1. New profile, start firefox
2. If you have no tabbar visible, middle click a bookmark to make it appear.
3. Drag and drop a bookmark onto the tabbar

Expected:
- Bookmark should open in a new tab

Actual:
- Nothing, or sometimes the bookmark might load in the tab with focus. Often the tab drop indicator is left visible after the drop action has completed.

Works 20071204_1722_firefox-3.0b2pre.en-US.win32
Broken 20071204_1813_firefox-3.0b2pre.en-US.win32

Checkins to module PhoenixTinderbox between 2007-12-04 17:22 and 2007-12-04 18:12 : 
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1196817720&maxdate=1196820779
Flags: blocking-firefox3?
When trying to drop a link or url onto the tab-bar I'm seeing this in the JS Console2: 

Error: aPostDataRef is undefined
Source file: chrome://browser/content/browser.js
Line: 1418

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007120505 Minefield/3.0b2pre Firefox/3.0 ID:2007120505
(Assignee)

Updated

11 years ago
Assignee: nobody → dietrich
Blocks: 398914
(Assignee)

Comment 2

11 years ago
Created attachment 291792 [details] [diff] [review]
fix

some consumers of getShortcutOrURI() only pass in the first argument.
Attachment #291792 - Flags: review?(sspitzer)
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
OS: Windows 2000 → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → Firefox 3 M10
Comment on attachment 291792 [details] [diff] [review]
fix

do we still need this check?

if (aPostDataRef && aPostDataRef.value)

that could now be

if (aPostDataRef.value)

right?
Attachment #291792 - Flags: review?(sspitzer) → review+
(Assignee)

Comment 4

11 years ago
Comment on attachment 291792 [details] [diff] [review]
fix

drivers: this is a regression from a P1 check-in yesterday (bug 398914). very small, low-risk fix.
Attachment #291792 - Flags: approvalM10?
(Assignee)

Comment 5

11 years ago
(In reply to comment #3)
> (From update of attachment 291792 [details] [diff] [review])
> do we still need this check?
> 
> if (aPostDataRef && aPostDataRef.value)
> 
> that could now be
> 
> if (aPostDataRef.value)
> 
> right?
> 

yes, i'll fix that for check-in.
(Assignee)

Comment 6

11 years ago
Created attachment 291824 [details] [diff] [review]
for check-in
Comment on attachment 291792 [details] [diff] [review]
fix

a=mconnor on behalf of drivers for 1.9 checkin
Attachment #291792 - Flags: approvalM10? → approvalM10+
(Assignee)

Comment 8

11 years ago
Checking in browser/base/content/browser.js;
/cvsroot/mozilla/browser/base/content/browser.js,v  <--  browser.js
new revision: 1.909; previous revision: 1.908
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+
Verified FIXED using:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007120704 Minefield/3.0b2pre

-and--

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007120705 Minefield/3.0b2pre
Status: RESOLVED → VERIFIED
Duplicate of this bug: 407467
You need to log in before you can comment on or make changes to this bug.