Interface of nsIDownloadManager does not contain the open method in JAVAXPCOM package

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: victor.gubin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (gutsy) Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (gutsy) Firefox/2.0.0.11

In documentation method open is present but not in java package. And you cannot use the default download manager UI. It is a big problem because code created for  for previous versions of Mozilla does not work. I consider that it is a problem of automatic generation of java code at build.

Reproducible: Always

Steps to Reproduce:
Just open the the MozillaInterfaces-src.jar package after the build firefox of xulrunner

Updated

11 years ago
Duplicate of this bug: 406980

Comment 2

11 years ago
What version of FF/XR did you build? nsIDownloadManager doesn't have an "open" method on trunk, but it does on the branch.
(Reporter)

Comment 3

11 years ago
I use codes from trunck - 1.9 GECO (from trunk) engine thus or error in documentation of covers features introduced in Firefox 3 

look here:
http://developer.mozilla.org/en/docs/nsIDownloadManager 
http://developer.mozilla.org/en/docs/nsIDownloadManager#open.28.29

and method of addDownload automatically must show the default user interface of DownloadManager or you cannot access for this interface.

I think that it would be not bad to do a nsIDownloadManagerUI interface as propery of nsIDownloadManager then it can be considerably simpler to use it. Or nsIDownloadManagerUI must have the contract id for accsess to default nsIDownloadManagerUI.

Comment 4

11 years ago
The documentation is a community effort... feel free to update it. As for the question of pluggable UI, if you would like to fix that please file a bug with a detailed proposal.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
We already have nsIDownloadManagerUI to show the UI on trunk:
http://mxr.mozilla.org/seamonkey/source/toolkit/components/downloads/public/nsIDownloadManagerUI.idl
(Reporter)

Comment 6

11 years ago
Sorry nsIDownloadManagerUI already have the contract id is 

@mozilla.org/download-manager-ui;1

I find it inside souse code.

Only what should be done is change documentation.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.