Prism 0.8 on Intel mac won't run two apps simultaneously

RESOLVED FIXED

Status

Mozilla Labs
Prism
--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Todd Slater, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Prism 0.8

Running Prism 0.8 on an Intel Macbook Pro 10.4.10, I can't run two webapps simultaneously; when trying to open the second app I get a dialog that says "A copy of Prism is already open. Only one copy of Prism can be open at a time."

I thought it might be related to <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=404692">bug 404692</a> but exporting MOZ_NO_REMOTE=1 didn't help.

Reproducible: Always

Steps to Reproduce:
1. Start web app
2. Start second web app
3. Dialog pops up about only one copy of prism can be open at a time.
Actual Results:  
I clicked OK and went to my regular firefox browser to do what I needed.

Expected Results:  
Allowed me to open more than one web app at a time.
Duplicate of this bug: 408215

Comment 2

10 years ago
This is a dup of bug 403727, right?

Comment 3

10 years ago
I don't think this is a dup of bug 403727. Without more digging, anyway, it doesn't look to be the same issue.

Comment 4

10 years ago
No, it is not a duplicate.
bug 403727 highlights the problem that one instance might crash all others on XP. This is a problem, but not a severe one.
On mac, however, the symptom is that you cannot launch more than one prism-app at the same time. Never. This is a major defect as it somehow prevents the typical usecase prism was designed for.
Now that bug 403727 is fixed, this works
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 6

10 years ago
mark, i'm looking for status on the mac issue that this bug represents and that i mentioned in bug 402317  

i was told this was a xulrunner design issue, not a prism bug.  

Comment 7

10 years ago
That's very cool, thanks!
When is a new official build (e.g. 0.9) planned to be made available?

Comment 8

10 years ago
when mark sais "this works" i am not certain if he means this mac issue or the xp issue that was referenced in this comment thread.  
?
bug 403727 is about the fact that when running 2 prism webapps, only 1 prism.exe process is used (you can check the Task Manager). That behavior has been fixed. Now each webapp has its own prism.exe process.

This bug (407017) is similar, in that xulrunner on mac checks to see if another XUL application is already using the profile and cannot run if the profile is locked (by another XUL application). This has been fixed as well, by the same code that fixed 403727. Since webapp are now in separate processes, they are also in different profiles.

Comment 10

10 years ago
great, thanks for clearing that up for me.
has the fix been applied to the latest xulrunner build?



A feature was added to xulrunner which allows a xul app to override default behavior and have 2 instances run in separate processes.

So yes, xulrunner nightlies have the feature, but prism also has changes to make use of the feature.

Comment 12

10 years ago
Where can one get a copy of the application (for Mac OS X) that has these changes?
You need to log in before you can comment on or make changes to this bug.