Error Console needs a "report a bug" option

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
11 years ago
2 years ago

People

(Reporter: zar, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

When an error occurs, 99.99999% of the end-users will not be able to slog through bugzilla to try to find it, and create a coherent bug report (only a small percentage of actual developers will).

It would be beneficial to everyone if the user could click on an error message (or messages) on the error console, and submit a bug report about what they just did to cause the problem, and how repeatable it is (while automatically adding the version numbers of all of their installed mozilla applications, plugins, themes, etc.).  

This will allow the developers to address problems that users are actually encountering, and statistics from this data would make it easier to assign priorities to bugs.

This would also be a helpful addition to the "help" menu "Report a bug...", for situations where there are no error messages in the Error Console.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
The Error Console doesn't show chrome errors (errors in Firefox's UI code) by default.  It only shows errors from web pages.  I guess it could be hooked up to "Report a broken web site"...

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 275362
(Reporter)

Comment 3

11 years ago
OK, this bug was marked a duplicate of "report an issue" in help menu (which has been marked RESOLVED WONTFIX).

So I have removed that suggestion from this bug description.  I agree that it may create more problems than it would solve.

However, when there is an ERROR (in the Error Console), I believe that there should be an easy way to report how it occurred.  This is a completely different situation than adding it to the help menu (which could make it too easy to complain about minor annoyances).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Error Console and Help menu need a "report a bug" option → Error Console needs a "report a bug" option

Comment 4

11 years ago
Robert, what do you think?  "Report broken website..." in the context menu for error console items?
(Reporter)

Comment 5

11 years ago
It might help narrow down problems.

I was using Lightning (Calender) with Thunderbird and I encountered a problem with accepting an invitation for a meeting, and that showed up on the error console.

Everyone at my company who is using Lightning is seeing the same problem.  There was a bug report that I eventually found and added a comment to.

Presumably the "Report broken website..." back-end uses some statistics to track how frequently a particular site is reported, so efforts can be focused.

Also, if there was an option to enable chrome errors, then it might make it easier to track those down as well.

Comment 6

11 years ago
(In reply to comment #4)
> "Report broken website..." in the context menu for error console items?

If you do that, please make sure that this is grayed out for strict warnings and CSS warnings, otherwise you'll get even more than the plethora of bugs à la

> Error in parsing value for property 'cursor'.  Declaration dropped.

which we already get from people mistaking harmless issues for real breakage!
I don't mind the addition personally, but there are some things to think about such as what was mentioned in comment #6.  

(Reporter)

Comment 8

11 years ago
Yes, it doesn't make sense for warnings.  But for true Errors, it should make it easy to report the cause.

The only complication that I can think of is that the errors accumulate over time.  There is already an enhancement request outstanding to timestamp the errors.  That will make it easier for someone to identify what they were doing to cause the most recent error.
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey

Comment 9

10 years ago
Comment #0 indicates that this bug was filed for Firefox, so -> Toolkit

SeaMonkey::Error Console -> Toolkit::Error Console
Component: Error Console → Error Console
Product: SeaMonkey → Toolkit
QA Contact: error-console → error.console
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago2 years ago
Resolution: --- → WONTFIX
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Ever confirmed: true
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
Version: unspecified → Trunk
The Error Console feature was removed entirely from the tree in Bug 1278368 and the bugzilla component is now being removed. We’ve migrated bugs that seem to also affect the Browser Console into the devtools component, please move this over if it was missed.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.