Installer could unintentionaly delete folder

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: ssu0262, Assigned: ssu0262)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
The fix to bug #37251 does not take into account a condition which could lead to 
the installer deleting a folder unintentionally.

1) user runs the installer and selects a destination path where a previously 
installed seamonkey#1 has been installed (essentially an upgrade).
2) user is prompted with dialog that the installer has detected the old 
seamonkey installation and recommends the user to let it delete it before 
continuing.  (the actuall deletion does not happen until after the user clicks 
Install in the last dialog)
3) user clicks the delete button and is shown the next dialog.
4) user changes mind and goes back to change path, and selects a different path 
which also contains a different old version of Seamonkey.  Let's call it 
seamonkey#2.
5) the installer happens to not detect that it's installing ontop of an old 
version of Seamonkey.  This is possible if the user deleted mozilla.exe, which 
happens to be the file that the installer keys off of to detect a previous 
installation.  I call this situation the "dumb user factor".
6) The user continues and clicks the install button and the installer deletes 
the seamonkey#2 folder without warning the user.

The problem is that the flag that indicates the user selected "Delete" is not 
being reset on each path change.  The fix is a simple one line change to always 
set/reset the flag.

This situation is extremely rare.  Most users will probably not run into this at 
all.  However, if they do, the consequences could be really bad.

I have the one line fix tested, reviewed, and ready to be checked in.  Just need 
approval now.
(Assignee)

Comment 1

19 years ago
nominating for nsbeta2
Status: NEW → ASSIGNED
Keywords: nsbeta2
(Assignee)

Comment 2

19 years ago
one line fix checked in.  a=dveditz, r=sgehani
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 3

19 years ago
build 2000-06-01-09
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.