crash [@ jsLookupPropertyWithFlags] when attempting to download message when subject is left blank

RESOLVED DUPLICATE of bug 317283

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 317283
10 years ago
10 years ago

People

(Reporter: Nick Kubiak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; .NET CLR 1.1.4322; FDM)
Build Identifier: version 2.0.0.9 (20071031)

When trying to download a message without a subject, the connection with the server freezes and then Thunderbird crashes.  I have tried with 3 different accounts (comcast, uiuc, and aol).  When conflicting message (the one without the subject) is deleted from the email server everything goes back to normal in Thunderbird.

Reproducible: Always

Steps to Reproduce:
1.Leave message subject blank.
2.Send message to email account that Thunderbird will download messages for.
3.If prompted with Message has No Subject Warning then delete the "(no subject)" so that dialog box is blank.
4.Then run "Get Mail" in order to recieve message.
5.Thunderbird will download message and then immediately crash.


Expected Results:  
Thunderbird should not crash even though someone accidentaly forgot to add a subject to the message.  Not all email clients have a no subject warning dialog therefore Thunderbird should have a measure to prevent crashing when there is no subject.

Comment 1

10 years ago
That isn't normally a problem, at least not for me. Can you give the talkback id of the crash? <http://kb.mozillazine.org/Talkback>
(Reporter)

Comment 2

10 years ago
The incident ID is TB38922804E.
(Reporter)

Comment 3

10 years ago
(In reply to comment #1)
> That isn't normally a problem, at least not for me. Can you give the talkback
> id of the crash? <http://kb.mozillazine.org/Talkback>

I found out that the problem has to do with the Bitdefender Toolbar 1.0 extension.  Disabling this extension fixes the problem for now.

Comment 4

10 years ago
The crash should be bug 317283.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Summary: crash when attempting to download message when subject is left blank → crash [@ jsLookupPropertyWithFlags] when attempting to download message when subject is left blank
Duplicate of bug: 317283
You need to log in before you can comment on or make changes to this bug.