Exchange: Copying a mail to another folder, deletes the mail from the original position

VERIFIED WORKSFORME

Status

MailNews Core
Networking: IMAP
P3
critical
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: Henrik Gemal, Assigned: Scott MacGregor)

Tracking

({imap-interop})

Trunk
x86
Windows 2000
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
If I select a mail on my Exchange IMAP server and right-click and select "Copy 
To" and select another folder on my Exchange server the mail is correctly copied 
but the "original" mail is also deleted!!!!!

Build 20000525

IMAP log:
1152[1dde558]: tarkin.ost.tele.dk:S-INBOX:CreateNewLineFromSocket: 13 OK FETCH 
fuldført.
1152[1dde558]: tarkin.ost.tele.dk:S-INBOX:SendData: 14 uid copy 9372 "Templates"
1152[1dde558]: tarkin.ost.tele.dk:S-INBOX:CreateNewLineFromSocket: 14 OK COPY 
fuldført. 1 meddelelser er kopieret.
1152[1dde558]: tarkin.ost.tele.dk:S-INBOX:SendData: 15 uid store 9372 +FLAGS 
(\Deleted)
1152[1dde558]: tarkin.ost.tele.dk:S-INBOX:CreateNewLineFromSocket: * 26 FETCH 
(FLAGS (\Seen \Answered \Deleted) UID 9372)
1152[1dde558]: tarkin.ost.tele.dk:S-INBOX:CreateNewLineFromSocket: 15 OK STORE 
fuldført.
(Assignee)

Comment 1

18 years ago
Hmm, I've tried this on our exchange server and couldn't reproduce it. I noticed
you were copying the message to your templates folder which is probably a local
folder. So I also tried copying the message to my local templates folder. It
still worked.

Are you sure you didn't use Move To by mistake =).

I'm using yesterday's bits not todays.
Status: NEW → ASSIGNED
Keywords: interop
QA Contact: lchiang → huang
(Reporter)

Comment 2

18 years ago
Damned.. I'm almost 110% sure I did the right thing. But I can seem to reproduce 
it right now.
I'll try to reproduce it... Will investigate!
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 3

18 years ago
ok, mark verified for now.
Henrik - if you see it again, pls reopen.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.