add redirect for /ebay/2.0.0.3-online/*/en/*

RESOLVED DUPLICATE of bug 399106

Status

mozilla.org Graveyard
Server Operations
--
major
RESOLVED DUPLICATE of bug 399106
10 years ago
3 years ago

People

(Reporter: kev, Assigned: aravind)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
Please add a redirect for http://addons.mozilla.org/ebay/2.0.0.3-online/*/en/* which will redirect download requests to http://addons.mozilla.org/ebay/2.0.0.3-online/*/en-US/*

We've found that Safari users (and potentially others) are receiving 404s when attempting to download the Firefox with Ebay Companion installer from AMO. Safari uses "en" instead of "en-US", and http://<locale>.www.mozilla.com/<locale>/add-ons/ebay/download.html will use that locale code for the locale location.

If a redirect could be added to point any users who try to hit the files under the en directory over to en-US, it would correct the 404s users are seeing. Alternatively, download.html could be modified to catch en and redirect to en-US.

If more information is required, please let me know.

Thanks!

kev
(Reporter)

Comment 1

10 years ago
err...

Safari uses "en" instead of "en-US", and
http://<locale>.www.mozilla.com/<locale>/add-ons/ebay/download.html will use
that locale code (en) for the download location from AMO.
Jeremy, is this something server ops setup? I don't see 2.0.0.3-online in the ebay directory or in our rewrite rules.
Moving to Server Ops for more attention and since I'm pretty sure it's something they will end up handling.
Assignee: nobody → server-ops
Component: Administration → Server Operations
Product: addons.mozilla.org → mozilla.org
QA Contact: administration → justin
Version: unspecified → other
(Reporter)

Comment 4

10 years ago
Okies. Could this be looked at today please? Let me know if it's something where more info is required, I'd like to be able to get a fix in by tomorrow, if possible. eBay has inquired on an ETA, and I'd love to get it addressed.

Thanks much, k.
(Assignee)

Updated

10 years ago
Assignee: server-ops → aravind
(Reporter)

Comment 5

10 years ago
Hey Aravind, my bad, it's releases.mozilla.com the download is initiated from.

So http://en.www.mozilla.com/en/add-ons/ebay/download.html tries to pull one of:

http://releases.mozilla.com/ebay/2.0.0.3-online/win32/en/Firefox%20Setup%202.0.0.6.exe
http://releases.mozilla.com/ebay/2.0.0.3-online/mac/en/Firefox%202.0.0.6.dmg
http://releases.mozilla.com/ebay/2.0.0.3-online/linux-i686/en/firefox-2.0.0.6.tar.gz

Which don't exist.

A redirect for the en directories is preferable because the release files do get updated from time to time.

kev
(Assignee)

Comment 6

10 years ago
http://en-us.www.mozilla.com/en-US/add-ons/ebay/download.html <-- that doesn't seem to work.

From comments 1 and 2, I *think* you guys want me to redirect

http://en.www.mozilla.com/en/add-ons/ebay/download.html to
http://en-us.www.mozilla.com/en-US/add-ons/ebay/download.html

Is that right?  If so, then the redirected page is also a 404.  

And now you want it to be redirected to the above releases.m.c urls?  Please clarify.


(Reporter)

Comment 7

10 years ago
The download page is referenced by:

http://en-us.www.mozilla.com/en-US/add-ons/ebay/

Which supplies the variables to download.html to redirect to releases

i.e. 

http://en-us.www.mozilla.com/en-US/add-ons/ebay/download.html?product=ebaybundle&os=win&lang=en-US

If you hit http://en.www.mozilla.com/en/add-ons/ebay/, you call http://en.www.mozilla.com/en/add-ons/ebay/download.html?product=ebaybundle&os=win&lang=en which generates a 404.

There's a couple ways to solve it, through a redirect or symlink on the webserver, or copying en-US as en on releases.
... or by fixing download.html to use en-US always instead of $lang, which can be en.
(Reporter)

Comment 9

10 years ago
but it needs to support en-GB, de, and fr as well
(Reporter)

Comment 10

10 years ago
Just to be clear, I'm open to any solution. Just looking for the most efficient one. If straight copying en-US to en is easiest for this, as the whole ebay on releases is a special case, I'm ok with that. Recoding download.html may just take more resources than it's worth.
(In reply to comment #9)
> but it needs to support en-GB, de, and fr as well

Not really... those are completely different files.

We have:
* en-US/add-ons/ebay/
* fr/add-ons/ebay/
* en-GB/add-ons/ebay/
* de/add-ons/ebay/

They are all separate... So, just changing en-US doesn't affect fr, en-GB, or de. The preferred fix to me would be to fix the website rather than rely on a server-side redirect.
(In reply to comment #10)
> Just to be clear, I'm open to any solution. Just looking for the most efficient
> one. If straight copying en-US to en is easiest for this, as the whole ebay on
> releases is a special case, I'm ok with that.

The problem is that "en" doesn't actually exist. It's just a symlink to "en-US". Supposedly, clouserw is working on a way to do the redirecting for en -> en-US (along with the several other locales we do this type of ab -> ab-CD redirect for) without using symlinks, but until then, we can easily just fix en-US's ebay pages to hardcode en-US instead of using $lang (which can be en or en-US).
(Reporter)

Comment 13

10 years ago
If http://en.www.mozilla.com/en-US/add-ons/ebay/download.html is a separate file from the other languages, I'm totally cool with that change. I just wasn't sure if there was a single, linked download.html or multiple files. 

fligtar, thoughts?
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 399106
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.