If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Dragging from inside to outside one window can raise another window

RESOLVED FIXED

Status

()

Core
Widget: Cocoa
P2
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: roc, Assigned: Josh Aas)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.89 KB, patch
smichaud
: review+
Details | Diff | Splinter Review
Steps to reproduce:
1) Press the mouse button in the topmost window
2) Drag outside that window, over another Firefox window
3) Release the button
4) Watch that other window raise
Flags: blocking1.9?
(Assignee)

Updated

10 years ago
Flags: blocking1.9? → blocking1.9+
(Assignee)

Updated

10 years ago
Priority: -- → P2
(Assignee)

Comment 1

10 years ago
Created attachment 292400 [details] [diff] [review]
fix v1.0
(Assignee)

Comment 2

10 years ago
Created attachment 292456 [details] [diff] [review]
fix v2.0

I realized that the window being brought forward is being caused by a synthetic mouse down, not Gecko's handling of the mouse up being sent to the background window. That synthetic mouse down is only meant for popup widgets, we can just not send it unless one exists.
Attachment #292400 - Attachment is obsolete: true
(Assignee)

Updated

10 years ago
Attachment #292456 - Flags: review?(smichaud)
Comment on attachment 292456 [details] [diff] [review]
fix v2.0

I'm sure this is right, so I'll r+ it without testing.

Too bad I missed it when I reviewed the patch for bug 406362 :-(
Attachment #292456 - Flags: review?(smichaud) → review+
(Assignee)

Updated

10 years ago
Attachment #292456 - Flags: superreview?(roc)
Attachment #292456 - Flags: superreview?(roc) → superreview+
(Assignee)

Comment 4

10 years ago
landed on trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.