Sender like "gemal@dk.net (Henrik Gemal)" should show "Henrik Gemal" in Sender column and not "(Henrik Gemal)"

NEW
Unassigned

Status

19 years ago
8 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
If you recieve a mail with a sender "gemal@dk.net (Henrik Gemal)" mozilla show 
the "gemal@dk.net" in the sender column.
Netscape 4.73 shows "Henrik Gemal" in the sender column.

It could be nice if Mozilla could show it the same way as Netscape.

A lot of Netscape employees has the way of formatting the sender address.

Comment 1

19 years ago
I'm not seeing this.  For example, I recently got a message from 
"selmer@netscape.com (Steve Elmer)" and it shows up as "Steve Elmer" in my from 
column.  Is anyone else seeing this?
(Reporter)

Comment 2

19 years ago
I've got a mail from:
lchiang@netscape.com (Lisa Chiang)
and it now shows up as:
(Lisa Chiang)
in my Sender column.

Summary: Sender like "gemal@dk.net (Henrik Gemal)" should show "Henrik Gemal" in Sender column and not "gemal@dk.net" → Sender like "gemal@dk.net (Henrik Gemal)" should show "Henrik Gemal" in Sender column and not "(Henrik Gemal)"
(Reporter)

Comment 3

19 years ago
Note that we're talking about mail, not News since it seems correct here.

Comment 4

19 years ago
I just want to understand what you are seeing.  Are you seeing the email address 
show up any more?  It sounds like you are not.  Are you seeing "(Lisa Chiang)" 
or "Lisa Chiang" in the sender column.  When I ran this a couple of days ago 
when trying to reproduce this bug, I was getting the version without the 
parentheses.
(Reporter)

Comment 5

19 years ago
Created attachment 9349 [details]
Screen shot of sender column when ypu have the header: From: gemal@dk.net (Henrik Gemal)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Comment 6

18 years ago
Lisa or someone in QA, are you able to reproduce this? I just would like to know 
how likely this is to occur.  I've yet to see this.
(Reporter)

Comment 7

18 years ago
This is only happening when viewing mail. A sender address 
like chofmann@netscape.com (Chris Hofmann) will be nicely formatted when viewed 
in a newsgroup...

To reproduce:
1) find a news posting (like 
news://news.mozilla.org/398212FA.5040707%40netscape.com)
2) View the news posting with Mozilla News and see that the sender address shows 
fine.
3) Take the source of the mail, including headers, etc. and use fx sendmail to 
send it as mail to yourself.
4) Watch as the sender addresse gets shown like (Chris Hofmann) in the sender 
column.

Really really weird!

Updated

18 years ago
Target Milestone: M18 → ---

Comment 8

18 years ago
Henrik, is this still occuring in the latest nightlies?
(Reporter)

Comment 9

18 years ago
If you have the following header in your mail:
lord@netscape.com (Bob Lord)

Then when readind a mail the Sender column in the message pane in build 20010312 
shows:
(Bob Lord)

while the From field in the mail pane shows:
Bob Lord <lord@netscape.com>

Some kind of sync between the two functions that retrieves the name and email 
address in the message pane and mail mail should be done!

Comment 10

14 years ago
No action in more than 3 years, can't this bug be closed?
Product: Browser → Seamonkey
Assignee: scottputterman → mail
Status: ASSIGNED → NEW
Priority: P3 → --
QA Contact: lchiang

Comment 11

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 12

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 13

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 14

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 15

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 16

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 17

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 18

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Comment 19

8 years ago
This is still an issue! Holy Cow! O_O
Tested with current SeaMonkey and Thunderbird trunk.

We definitely need a unit/interface/wossname for RfC-compliant email parsing/creation...
Assignee: mail → nobody
Status: RESOLVED → REOPENED
Component: MailNews: Message Display → MIME
Ever confirmed: true
OS: Windows 2000 → All
Product: SeaMonkey → MailNews Core
QA Contact: mime
Hardware: x86 → All
Resolution: EXPIRED → ---

Updated

8 years ago
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.