If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Account wizard not appearing when 3pane is launched

VERIFIED FIXED in M17

Status

SeaMonkey
MailNews: Account Configuration
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: kmurray1115, Assigned: Alec Flett)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

Attachments

(1 attachment)

585.99 KB, application/octet-stream
Details
(Reporter)

Description

18 years ago
If I create a new profile, or launch Seamonkey for the first time without 
migrating or Activating, the New Account Set Up Wizard should launch, even 
before the UI builds.
(Reporter)

Comment 1

18 years ago
Created attachment 9204 [details]
bitmap of New Account Set up

Comment 2

18 years ago
What do you mean, Kevin?  We launch the mail account wizard when the user first 
does anything with mail (ie. bring up mail window, etc).  You want us to launch 
the account wizard for mail even though the user may not want to set up mail?
QA Contact: lchiang → nbaca

Comment 3

18 years ago
I was sitting in Kevin's cube when he tested this.  The mail 3 pane came up
empty.  He clicked on Edit|prefs and got a prefs panel.  _Then_, the account
setup wizard showed up and he had all 3 open simultaneously.  This is a very
confusing experience.

We need to make the account setup wizard come up modally _BEFORE_ showing the
mail UI!
(Assignee)

Comment 4

18 years ago
This is a timer bug, has nothing to do with modality or anything... the behavior 
you are seeing is new and was not intended. 

The timer somehow fired after the prefs window opened... what platform was this 
on? This probably needs to go to danm...

Dan, this window opens on a zero-length JS timer after the onload of the 3pane 
window.... so it basically sounds like the timer event is not being fired until 
another modal window appears.
Summary: Go to Account SetUp Wizard if no mail account on launch → Account wizard not appearing when 3pane is launched

Comment 5

18 years ago
It was a windows platform, either NT or 98.  Kevin?

Comment 6

18 years ago
Build 2000-06-01-09M16: Win95

I couldn't reproduce the problem until I deleted my mozreg and Users50 directory 
and started mail again. Now the Wizard doesn't automatically appear when the 
3pane appears. After opening the Account Settings dialog (Edit|Mail/News Account 
Settings) then the Wizard launches.

Updated

18 years ago
Keywords: nsbeta2

Comment 7

18 years ago
[nsbeta2+]
Whiteboard: [nsbeta2+]
(Assignee)

Comment 8

18 years ago
this is a timer bug, I don't know who to assign this to.. I'm going to start
with trudelle and see where this ends up...
Assignee: alecf → trudelle

Updated

18 years ago
Assignee: trudelle → pavlov

Comment 9

18 years ago
giving to pavlov for triage- Pav, you've been all over the timer code recently, 
perhaps you know how to handle this?

Comment 10

18 years ago
to quote alecf:
Pavlov_: here's what's supposed to happen
- you click the mail icon
- the mail 3pane popps up
- the account wizard pops up

this is how it works for me.  the account wizard pops up modally and on top of
all other windows when i launch mail for the first time.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
Reopening. Build: 2000060708, MacOS 9.0.

To reproduce:
* Install Mozilla someplace where you need proxy authentication.
* Start Mail.

What should happen:
* Just the account wizard appears, without a three-pane window. (Why? See the
  following ...)

What actually happens:
* The three-pane window appears.
* The account wizard appears.
* The proxy authentication dialog appears on top of the account wizard (because
  the three-pane window is trying to load the start page).
* You can not get rid of the proxy authentication dialog without getting rid of
  the account wizard first, in spite of the fact that it's the proxy
  authentication dialog which is on top.

There is no point in having a mail window open without any accounts set up. It 
just exposes a whole lot of completely useless UI to the user. In addition, it 
leads to too much possibility for other bugs like this one -- trying to send 
messages when no accounts are set up, trying to get messages when no accounts are 
set up, throwing dialogs for the start page which modally conflict with the 
account wizard, et cetera ad nauseum.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 12

18 years ago
reassigning back to mailnews
Assignee: pavlov → alecf
Status: REOPENED → NEW

Comment 13

18 years ago
moving to M17
Target Milestone: --- → M17
(Assignee)

Comment 14

18 years ago
oh, for another bug I made this not fire on the timer, so this should start 
working anyway.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 15

18 years ago
Build 2000-06-26-09M17: NT4, Linux 6.0, Mac 9.04
Verified Fixed. Using a new profile, used the menu item to launch mail, the Mail 
3-pane appeared followed quickly by the Account Wizard. 
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.