mozilla crash when access to Hyundai home page [@ libc-2.6.1.so@0x71cbc - libflashplayer.so@0x13b3e4]

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Fco. Javier, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.1.10) Gecko/20071015 SUSE/2.0.0.10-0.1 Firefox/2.0.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.1.10) Gecko/20071015 SUSE/2.0.0.10-0.1 Firefox/2.0.0.10

Hyundai web page use Adobe Flash technology. When try to view the main page Mozilla Firefox crash. I use 9.0.48.0 version of Flash player. I don't know if the problem is from Adobe Flash player of from Firefox. Please, confirm it.

Reproducible: Always

Steps to Reproduce:
1.Open Mozilla Firefox.
2.Open http://hyundai.es Home Page.
3.Mozilla Firefox crash.
Actual Results:  
Mozilla Firefox crash.

Comment 1

10 years ago
Does it crash immediately or it takes a while or you have to do something to get it to happen?
Can you try with a mozilla.org build or your own build?  (Firefox 2.0.0.11 first and then trunk if you're willing to test less stable code)
Can you get a stack?  you might be able to get something from the suse build with gdb but it might not have symbols.  2 good ways to get stacks are 1) grabbing a mozilla.org build and using the built in reporter (talkback <http://kb.mozillazine.org/Talkback> for firefox2 and breakpad <http://kb.mozillazine.org/Breakpad> for trunk/firefox3) and then giving us the ID of the crash or 2) building your own firefox and using gdb.

If you have trouble with any of that the support options at http://www.mozilla.org/support/#community are a good place to go.  (many people from here help out at those too, including myself)
Keywords: crash
Whiteboard: CLOSEME 01/07

Comment 2

10 years ago
I can reproduce the crash using Firefox 2.0.0.11 and Flash 9.0 r48:
TB39042862G
The crash appears to be in the Flash plugin code.
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → plugins
Whiteboard: CLOSEME 01/07

Comment 3

10 years ago
I can crash a trunk build as well http://crash-stats.mozilla.com/report/index/5d6a9dee-a921-11dc-925e-001a4bd43ef6?date=2007-12-13-02

Comment 4

10 years ago
Signature	libc-2.6.1.so@0x71cbc
UUID	5d6a9dee-a921-11dc-925e-001a4bd43ef6
Time	2007-12-12 18:15:59-08:00
Build ID	2007121204
OS	Linux
OS Version	0.0.0 Linux 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux
CPU	x86
CPU Info	AuthenticAMD family 1 model 44 stepping 2
Crash Reason	SIGSEGV
Crash Address	0xb699fcbc

Frame 	Signature 	Source
0 	libc-2.6.1.so@0x71cbc 	
1 	libflashplayer.so@0x13b3e4 	
2 	libflashplayer.so@0x13c159 	
3 	libflashplayer.so@0x50da1c 	
4 	libflashplayer.so@0x413025 	
5 	libflashplayer.so@0x432272 	
6 	libflashplayer.so@0x454bcc 	
7 	libflashplayer.so@0x454b07 	
8 	libflashplayer.so@0x4facdb 	
9 	libflashplayer.so@0x2b043 	
10 	libflashplayer.so@0x2bad8 	
11 	ns4xPluginStreamListener::CleanUpStream(short) 	mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp:168
12 	ns4xPluginStreamListener::OnStopBinding(nsIPluginStreamInfo*, unsigned int) 	mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp:719
13 	nsPluginStreamListenerPeer::OnStopRequest(nsIRequest*, nsISupports*, unsigned int) 	mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp:2397
14 	nsStreamListenerTee::OnStopRequest(nsIRequest*, nsISupports*, unsigned int) 	mozilla/netwerk/base/src/nsStreamListenerTee.cpp:65
15 	nsHttpChannel::OnStopRequest(nsIRequest*, nsISupports*, unsigned int) 	mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp:4412
16 	nsInputStreamPump::OnStateStop() 	mozilla/netwerk/base/src/nsInputStreamPump.cpp:576
17 	nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) 	mozilla/netwerk/base/src/nsInputStreamPump.cpp:401
18 	nsInputStreamReadyEvent::Run() 	mozilla/xpcom/io/nsStreamUtils.cpp:111
19 	nsThread::ProcessNextEvent(int, int*) 	mozilla/xpcom/threads/nsThread.cpp:510
Summary: mozilla crash when access to Hyundai home page → mozilla crash when access to Hyundai home page [@ libc-2.6.1.so@0x71cbc - libflashplayer.so@0x13b3e4]

Comment 5

10 years ago
Does this crash happen with the latest Flash Player, version 9r115: www.adobe.com/go/getflashplayer

Comment 6

10 years ago
(In reply to comment #5)
> Does this crash happen with the latest Flash Player, version 9r115:
> www.adobe.com/go/getflashplayer
> 

Sorry forgot to mention, yes it does.

Comment 7

10 years ago
from Adobe QA in January

Hello Mr. Brosnan,
Thank you for submitting your recent Flash Player issue regarding Flash Player crashing on http://hyundai.es.  I have been able to reproduce the crash and have submitted a bug report to the Engineering Department.

Best Regards, 
Maria Vargas Quality Engineer, Flash Player

Need to check if beta 10 or v124 fixes this.

Comment 8

10 years ago
works for me with Flash 10 rc, http://blogs.adobe.com/penguin.swf/2008/08/10rc1.html
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 9

10 years ago
Mike Melanson from Adobe emailed me and said Adobe still has an open issue for this. Is there a bug in the Adobe JIRA that could be followed?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 10

10 years ago
Dang misread the email from Mike. 

"Yes, we were able to reproduce that bug and specifically addressed it in the latest Flash Player 10 RC. I would add notes to the report but I can’t seem to log into Bugzilla."
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
(Assignee)

Updated

7 years ago
Crash Signature: [@ libc-2.6.1.so@0x71cbc - libflashplayer.so@0x13b3e4]
You need to log in before you can comment on or make changes to this bug.