Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 407413 - Default margins are too low for A4 printing size
: Default margins are too low for A4 printing size
Status: RESOLVED DUPLICATE of bug 130075
Product: Core
Classification: Components
Component: Printing: Output (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Jet Villegas (:jet)
Depends on:
  Show dependency treegraph
Reported: 2007-12-07 13:33 PST by Pacho Ramos
Modified: 2008-04-19 06:15 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

Example erroneous print (29.14 KB, application/pdf)
2008-01-29 07:12 PST, Victor Engmark
no flags Details

Description Pacho Ramos 2007-12-07 13:33:56 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; es-ES; rv: Gecko/20071205 Firefox/
Build Identifier: 

Firefox/Seamonkey default to 0.04 inches as default margins for printing. These values are too small causing text to be cut off. 

I have done some tests and the best value for me is "0.14 inches" for ALL margins

Thanks a lot for fixing  this

Reproducible: Always

Steps to Reproduce:
Comment 1 Victor Engmark 2008-01-29 07:11:38 PST
I get the same problem, no matter what I set the margins to. Example attached, printed to PDF with the following settings:
user_pref("print.postscript.cups.enabled", true);
user_pref("print.postscript.paper_size", "A4");
user_pref("print.print_printer", "foo");
user_pref("print.printer_CUPS/foo.print_bgcolor", false);
user_pref("print.printer_CUPS/foo.print_bgimages", false);
user_pref("print.printer_CUPS/foo.print_colorspace", "default");
user_pref("print.printer_CUPS/foo.print_command", "lpr ${MOZ_PRINTER_NAME:+-P\"$MOZ_PRINTER_NAME\"}");
user_pref("print.printer_CUPS/foo.print_downloadfonts", false);
user_pref("print.printer_CUPS/foo.print_evenpages", true);
user_pref("print.printer_CUPS/foo.print_footercenter", "");
user_pref("print.printer_CUPS/foo.print_footerleft", "");
user_pref("print.printer_CUPS/foo.print_footerright", "");
user_pref("print.printer_CUPS/foo.print_headercenter", "");
user_pref("print.printer_CUPS/foo.print_headerleft", "");
user_pref("print.printer_CUPS/foo.print_headerright", "");
user_pref("print.printer_CUPS/foo.print_in_color", true);
user_pref("print.printer_CUPS/foo.print_margin_bottom", "0.5");
user_pref("print.printer_CUPS/foo.print_margin_left", "0.5");
user_pref("print.printer_CUPS/foo.print_margin_right", "0.5");
user_pref("print.printer_CUPS/foo.print_margin_top", "0.5");
user_pref("print.printer_CUPS/foo.print_oddpages", true);
user_pref("print.printer_CUPS/foo.print_orientation", 0);
user_pref("print.printer_CUPS/foo.print_pagedelay", 500);
user_pref("print.printer_CUPS/foo.print_paper_data", 0);
user_pref("print.printer_CUPS/foo.print_paper_height", "297.00");
user_pref("print.printer_CUPS/foo.print_paper_name", "A4");
user_pref("print.printer_CUPS/foo.print_paper_size", 0);
user_pref("print.printer_CUPS/foo.print_paper_size_type", 1);
user_pref("print.printer_CUPS/foo.print_paper_size_unit", 1);
user_pref("print.printer_CUPS/foo.print_paper_width", "210.00");
user_pref("print.printer_CUPS/foo.print_plex_name", "default");
user_pref("print.printer_CUPS/foo.print_resolution_name", "default");
user_pref("print.printer_CUPS/foo.print_reversed", false);
user_pref("print.printer_CUPS/foo.print_scaling", "  1.00");
user_pref("print.printer_CUPS/foo.print_shrink_to_fit", true);
user_pref("print.printer_CUPS/foo.print_to_file", false);
user_pref("print.printer_CUPS/foo.print_to_filename", "/home/username/");
Comment 2 Victor Engmark 2008-01-29 07:12:37 PST
Created attachment 300015 [details]
Example erroneous print

Printed from
Comment 3 rsx11m 2008-02-26 11:01:52 PST
This is not restricted to A4 paper size, also occurs with US Letter.

Ideally, the 0.04 inch would be counted from the printable area, and not from the full paper area. Thus, the PostScript module would need to obtain this information from CUPS and apply those margins accordingly.

Some distributions override those settings as a workaround, e.g., this is what comes with OpenSUSE in all-novell.js:

> pref("print.print_edge_top", 14); // 1/100 of an inch
> pref("print.print_edge_left", 16); // 1/100 of an inch
> pref("print.print_edge_right", 16); // 1/100 of an inch
> pref("print.print_edge_bottom", 14); // 1/100 of an inch

which doesn't fit for some printers either though.
Comment 4 rsx11m 2008-03-29 10:56:32 PDT
The original description as well as my comment #3 appear to be duplicates of
bug 130075, the main issue being how to identify the printable paper area.

This may also be related to bug 417356.

As for comment #1, I don't see any of the print.*.print_edge_* preferences
set, thus you may not have modified the correct settings (those are in the
printer properties dialog, not the margins in the general page setup).
The printout in comment #2 is in US-letter format, thus cropped by 0.69'' at
the top, making it hard to see if the top headers are present or not.
Comment 5 rsx11m 2008-04-04 15:30:38 PDT
> (comment #3) Thus, the PostScript module would need to obtain this
> information from CUPS and apply those margins accordingly.

The best fit for this would be bug 284925 (general bug for CUPS parameters).

Unless either of you gets back with more information within the next two weeks, I think that this is bug 130075 and should be resolved as a duplicate then.
Comment 6 Pacho Ramos 2008-04-05 02:45:51 PDT
I don't know if this is exact the same problem :-/, now I use opensuse's workaround and work ok for me :-|

Sorry for not giving you much more info :-(
Comment 7 rsx11m 2008-04-05 07:24:20 PDT
If increasing the margins brings the headers and footers completely into the printable area of your printer, it is the same problem as described here.
Comment 8 Pacho Ramos 2008-04-05 08:40:48 PDT
Yes, all info is printed fine using this workaround.
Comment 9 rsx11m 2008-04-19 06:15:34 PDT
No more comments came in, thus resolving.

*** This bug has been marked as a duplicate of bug 130075 ***

Note You need to log in before you can comment on or make changes to this bug.