Empty list space in extension manager acts as extension with focus when it should do nothing (extension theme manager)

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
minor
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Gabriel Chadwick, Unassigned)

Tracking

({polish})

Trunk
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
In extension manager double clicking in space under extension list opens option menu of extension that as focus when it should do nothing. It's all said.

Comment 1

11 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.4; en-US; rv:1.9b1) Gecko/2007120816 Minefield/3.0b1

Can reproduce. For each extension there is a row with Preferences, Disable, Uninstall...

To reproduce:
1) Pick an extension that has the preferences button enabled.
2) Double click anywhere in that row except one of the buttons.

It opens up the preferences pane even though preferences was not clicked.

Expected result:
Nothing happens.
Brett, iirc it was decided quite some time ago that the default action when double clicking an extension should be to open the extension's options and for a theme should be to "Use Theme". I believe what the reporter is stating is that double clicking an empty area of the richlistbox when an extension is selected opens the extension's options which is not correct behavior. I believe this is the same root cause as bug 405492.
(Reporter)

Comment 3

11 years ago
(In reply to comment #1)
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.4; en-US; rv:1.9b1)
> Gecko/2007120816 Minefield/3.0b1
> 
> Can reproduce. For each extension there is a row with Preferences, Disable,
> Uninstall...
> 
> To reproduce:
> 1) Pick an extension that has the preferences button enabled.
> 2) Double click anywhere in that row except one of the buttons.
> 
> It opens up the preferences pane even though preferences was not clicked.
> 
> Expected result:
> Nothing happens.
> 

That is not what I am reporting... I ma speaking of the empty space under the list of extensions.

Furthermore, the empty space will also act as clicking on the extension when using right mouse click.
Summary: Double clicking in space under extension list opens option menu of extension that as focus when it should do nothing (extension theme manager) → Empty list space in extension manager acts as extension with focus when it should do nothing (extension theme manager)
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Updated

10 years ago
Keywords: qawanted
(Reporter)

Comment 4

8 years ago
WFM in new extension manager. Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:2.0b2pre) Gecko/20100701 Minefield/4.0b2pre
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.