Mouse-Wheel scrolling doesn't work over some embedded flash videos

RESOLVED DUPLICATE of bug 483136

Status

()

RESOLVED DUPLICATE of bug 483136
11 years ago
10 years ago

People

(Reporter: mathieu.johnson, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112112 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112112 Minefield/3.0b2pre

Mouse-Wheel scrolling doesn't work over some embedded videos . It works on some embedded flash videos (like youtube.com) but not on the site I linked to.

It works in Firefox 2, IE7 and IE6



Reproducible: Always

Steps to Reproduce:
1.Go to URL
2.Scroll with the mouse-wheel when cursor is over the embedded video
3.Notice the immobility of the page
Actual Results:  
The page does not scroll

Expected Results:  
The page scrolls
(Reporter)

Updated

11 years ago
Summary: Mouse-Wheel scrolling doesn't work over some embedded videos → Mouse-Wheel scrolling doesn't work over some embedded flash videos
(Reporter)

Comment 1

11 years ago
Could someone please confirm this ?

Comment 2

11 years ago
Confirming on Linux with Firefox 3 nightly build from 2008-02-28 (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008022804 Minefield/3.0b4pre).

When I hover the mouse cursor over the embedded video, mouse wheel doesn't scroll. However, keyboard cursor keys still work for scrolling.

Updated

11 years ago
Component: General → Widget: Win32
Product: Firefox → Core
QA Contact: general → win32
(Reporter)

Updated

11 years ago
OS: Windows XP → All
(Reporter)

Updated

11 years ago
Component: Widget: Win32 → Widget

Comment 3

11 years ago
Confirming on both Firefox 3 Beta 4 and now 5 on Windows XP SP2, with Flash 9.0.115.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5 ID:2008032620

Like the OP said, this worked fine in FF2.

Comment 4

11 years ago
i also experience this problem, only on certain flash sites though, more details are.

Scrolling over page fine,

Mouse scrolling over the flash object BEFORE the play button is pressed doesnt work, but as soon as the mouse is off the flash object, the page scrolls.

After the play button is pressed and the flash object is clicked on, the page wont scroll anywhere, without first clicking on another part of the html document first.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5  

Comment 5

10 years ago
Still getting this problem with some sites and videos in RC1. Here's another example page:

http://www.videogaming247.com/2008/05/16/five-new-in-game-silent-hill-5-movies-posted/

Comment 6

10 years ago
Can confirm this problem occurs on (all I've tried so far) http://news.bbc.co.uk/ flash presentations - both up and down doesn't work as soon as mouse enters flash display area. Moving back out re-enables it - no click required.

Problem only manifests itself after video has loaded - during the load period - flash has already put up its [blank] display - scrolling still works.

Try the live bbc news channel link at the top of the main news front page - http://news.bbc.co.uk/1/hi/uk/7459669.stm.

I'm running FF 3.0 on Win XP SP3. Does it on XP SP2 too.

Standard MS 2 button + scroll wheel mouse - USB.

IE7 on the same PC has no such problem.

Comment 7

10 years ago
Full FF version info here: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

Comment 8

10 years ago
Created attachment 340763 [details]
flash stops scrolling on mouseover testcase

Comment 9

10 years ago
tested on latest trunk and still not fixed
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080927033433 Minefield/3.1b1pre

Found the regression window:
Works:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2006/05/2006-05-01-05-trunk/

Broken:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2006/05/2006-05-02-04-trunk/

Both were tested with Adobe Flash 9.0.124.0 on Windows XP.

Comment 10

10 years ago
I can confrim with recent Linux trunk build.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20080928200351 Minefield/3.1b1pre
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

10 years ago
confirm regression range. and still broke for Flash v10 and Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3


http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=&branchtype=match&dir=%2Fmozilla%2F&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-05-01-02+00%3A00%3A00&maxdate=2006-05-02-04+00%3A00%3A00&cvsroot=%2Fcvsroot

caused by bug 334650?  (was backed out according to bug comments)
Keywords: regression

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 483136
You need to log in before you can comment on or make changes to this bug.