Duplex printing of selection inconsistently available

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Jim Lerner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

There is some broken logic surrounding the enabling of the "print selection only" option on the print dialog.  Printer is a Lexmark C530dn using the Lexmark driver on MacOS X 10.5.1.  With some text highlighted from any web page, if I choose the Duplex preset, Print Selection Only is disabled.  However, if I first change from print all pages to printing specific pages (including the entire range) and change focus to the last page number, the Print Selection Only checkbox is enabled.  I can then check it, and then change from Standard to Duplex.  Printing then works exactly as it should: the selection is printed, duplexed.  The only bug I am reporting is that the enable/disable of the Print Selection Only checkbox is funky.

Reproducible: Always

Steps to Reproduce:
1. Highlight some text on a displayed web page.
2. File->Print
3. Choose a duplexing printer (eg. Lexmark C530dn)
4. Choose Duplex preset.

Actual Results:  
Print Selection Only checkbox is disabled.

Expected Results:  
Print Selection Only checkbox should be enabled, since there is a selection.

Workaround:


1. Choose Standard preset
2. Confirm that Print Selection Only checkbox is disabled.
3. Change from Print All Pages to pages 1-1 and click on one of the two page numbers.
4. Confirm that Print Selection Only checkbox is enabled.
5. Check (select) Print Selection Only.
6. Change to Duplex preset.
7. Confirm that Print Selection Only remains enabled and checked.

Comment 1

8 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a5pre) Gecko/20100531 Minefield/3.7a5pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.