If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

All repeating events moved from WebDav to CalDav disappear after November 2008

RESOLVED INVALID

Status

Calendar
Provider: CalDAV
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: dekkerdreyer, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Lightning 0.7 release on Thunderbird 2.0.0.9 (20071031)

All my repeating events stop repeating after November 2008.  This appears to only be an issue with a CalDav server.  Lightning, connected to Darwin Calendar Server, doesn't show repeating events past November 2008.  The same event, saved on a WebDav, works fine.

It is unknown if this is a problem with Darwin Calendar Server or Lightning, but the Mulberry calendar program connected to the same CalDav calendar does show the repeating event beyond November 2008 as expected.

Reproducible: Always

Steps to Reproduce:
1. Create a repeating event on a CalDav (such as Darwin Calendar Server)

Actual Results:  
Event repeats through November 2008, then stops.

Expected Results:  
Event repeats without stopping.

This is a subversion checkout of the latest Darwin Calendar Server.  Mulberry calendar client does not exhibit same issue.

If the event created is a daily or weekly event, it is visible in "Month" view for November 2008 but not for December 2008.  When the view is changed to "Multiweek", the view for "Weeks 48-52" (starting with November 23rd, 2008) shows the repeating event every week (including visible part of December 2008 up through the 27th).  Changing the view to "Weeks 49-1" (starting with November 30th, 2008) causes the previously displayed events to disappear.
(Reporter)

Comment 1

10 years ago
Created attachment 292314 [details]
Multiweek view, weeks 48-52
(Reporter)

Comment 2

10 years ago
Created attachment 292315 [details]
Multiweek view, weeks 49-1

Comment 3

10 years ago
I can confirm that this happens with Apple CalendarServer, but also that it does *not* happen with Bedework, Chandler Server, nor DAViCal. Wiresharking one of the requests described above shows CalendarServer returning an emply multistatus; it looks to me very much like CalendarServer is not expanding recurring events farther than about a year in the future. Since that's described as a MUST in para 7.4 of the spec I'm thinking this is probably an Apple bug rather than a Mozilla one. Leaving this one open for now, though, pending further investigation.

Comment 4

10 years ago
Glancing at the CalendarServer source, it by default expands recurring events 356 days in the future, but should still be expanding them past that as needed for specific queries. So it looks to me like the bug here is an Apple bug rather than a Mozilla one, and I'm closing the Mozilla one. Please re-open if you find reasons to think that I'm wrong.

->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.